Custom modules and the Web IDE

Posted on
  • I have just moved from the Chrome Web App to using and I can't load my custom modules.

    I have added to "Settings > Communications > Module URL" however on upload the modules are not found and the console reports:

    Loading modules loadModule(QMC5883L) ERROR: getURL("­L.min.js") error :
    HTTP 404 ERROR: getURL("­L.js")
    error : HTTP 404 ERROR:
    error [object ProgressEvent] ERROR:
    error [object ProgressEvent] WARNING: [notify_warn] Module QMC5883L
    not found

    I have also tried from an https:// address and get the same error. The URL, both file: and https:, are working from another tab in the same brower (Chrome on MacOS).

    Anyone know what I am doing wrong?

  • Found it:

    • using the https url I am seeing a CORS error in the javascript console.
    • using the file: url I am seeing "Not allowed to load local resource" error in the javascript console.
  • And for anyone else I got it working locally with:

    npm install -g http-server
    http-server --cors ./

  • Great! Glad you got it sorted!

    A few days ago someone mentioned that they might have a go at re-adding projects support to the online IDE (it has to be done using a different API) so it may be things get easier in a month or two

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Custom modules and the Web IDE

Posted by Avatar for user148332 @user148332