• Just noticed that an app I was working on showed up as "Unknown app" and it offers to to upgrade it. Selecting this causes the App Loader to murder (delete everything but the .info file) it. No big deal but also probably not what should be happening.

    On a related note or is the "Upgrade" symbol maybe the wrong symbol- I would expect an arrow pointing straight up (with maybe line(s) under it). The symbol is more "reload/refresh/maybe update" than "upgrade".

  • Ok, thanks! Although I just tried here (see attached) and I don't see an update option.

    Do you think you could point me at exactly what you uploaded so I can try and reproduce here?

    On a related note or is the "Upgrade" symbol maybe the wrong symbol

    I'm open to suggestions, but I feel like it needs to be different enough to the upload symbol (which is also an arrow from a bar :) ). I'd have thought that could be more confusing...

    1 Attachment

    • Screenshot at 2021-11-18 09-16-48.png
  • I cannot reproduce it either now. Simply reopening the browser must have fixed it. I managed to do it twice (upgrading left the .info file and i could "uninstall" that then). but its gone now.

    You can grab the code I was playing with from here:
    Maybe you can tell something from the handmade info file.

  • Okay it happened again. Freshly opened chrome window -however I had an outlook web instance running in another chrome window.

    1 Attachment

    • Screenshot_20211119_102809.png
  • Ahh - thanks! Right, I guess maybe it happens when the app has a version number in the app info - since I didn't on mine and it was ok.

    filed an issue at https://github.com/espruino/BangleApps/i­ssues/927 and I'll try and look at it later

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

App Loader will offer to update Unknown Apps and murder them ;)

Posted by Avatar for blkhawk @blkhawk