App uploading failure

Posted on
  • Hello

    Got a bangle.js sometime ago and used it on and off with the initial firmware (2v05).

    The watch could connect to the IDE, respond to commands and in general function as expected.

    I tried updating the bootloader but I got a failure message. I tried updating or downloading other stuff from the app loader, same failure messages.

    I then updated the firmware to 2v06 without any hitch but I am still getting the same behaviour. I can still connect to the watch and everything but I cannot update any applications.

    Any ideas on what may be going on?

    All the best

  • Hi! Is it possible that you have Programmable set to off in settings?

    I would suggest using the instructions at­ting-without-loading-any-code to reboot Bangle.js without loading any code - you should then be able to connect just fine and update all the apps.

    I guess another option might be that one of your other devices is paired to the Bangle and then automatically connects to it as soon as it sees it in range?

  • Hello @Gordon thank you very much for your response. I had gone through all the guidance online and any other thing I could think of. Finally, I think it was all the RF "crap" in the background in the room I was in. I was just about to leave a comment that this seems to be solved when I try in a "quiet" room. Uploaded / Downloaded, reset stuff, it seems fine for the moment :)

    Thank you very much. All the best.


App uploading failure

Posted by Avatar for aanastasiou @aanastasiou