Got d1-mini clones and not able to flash them

Posted on
of 2
/ 2
  • Fri 2020.04.03

    @opichals I too have had success with WAVGAT, haven't stumbled across WeMos though, but checking that page, and beneath the Overview tab:

    Package Included:
    1×WeMos D1 mini

    Maybe there is a subtle difference in board design? Is there underside silkscreen that definitively states it isn't a WeMos brand? You then might consider a refund 'Not as Advertised' request, as title doesn't match what's included doesn't match image.­html

    Oops, didn't really understand the 'Tasmota' reference, before I posted

  • The fact that the Tasmota firmware works without any issues makes me think about what Espruino needs changing to support these particular ESP8266s as well.

  • So it is not running yet - correct?

    maybe there are some wrong setting in user_rf_cal_sector_set()­b/21e84735c5349c7566291821ac40b9154d0459­f1/targets/esp8266/user_main.c#L326-L348­

  • No, it is not. I was too optimistic when I was able to connect to it.

    The wifi.connect() call consistently crashes it.

    @MaBe I haven't looked into these addressing specifics before. I have tried flashing it as 1MB/2MB and 4MB boards and none of those seemed to help.

    Any suggestions?

  • You could try a older firmware, pick one from here

  • I think I tried 1.99 (for 4MB) and had the same issue. Let me get back to it once I have some time again to spend on this. Perhaps there was something I missed in those tests. It was a lot of combinations in a single weekend.

  • Fri 2020.04.03

    While this is three years old, and on a WAVGAT brand, here is the exact commnd I used for the version specified then. The device worked last time I powered up, over a year ago!!­084/

    Also check out post #19 as another more recent added content

  • Did some test with different board

    1. poor usb to serial chips or driver implementation need slow baud rate like 115200
    2. flash modes like qio/dio are esp-vendor-board specific

    Workaround for 1. is to use a usb to serial adapter directly connected to TX, RX and GND to use higher baud rates.

  • I used

    python "../../../esptool/" --port COM9 --baud 115200 write_flash --verify --flash_freq 80m --flash_mode dio --flash_size 32m 0x0000 "boot_v1.6.bin" 0x1000 espruino_esp8266_user1.bin 0x3FC000 esp_init_data_default.bin 0x37E000 blank.bin

    to flash the files to my LoLin NodeMCU with a esp8266, but when I connect to espruino web IDE, it always just spams

    >>> Sending...
    ---> "\u0010print(\"<\",\"<<\",JSON.stringify­(process.env),\">>\",\">\")\n"
    >>> Sent
    >>> Receiving...
    WARNING: No result found for "process.env" - just got "H!È\b1§D\u0000\u000e~¦¤|×\u0018!Æ\t\f¸1­DjGI|àôH!Èy!D\u0000uLfDHÄÊ\u0018!\u0000\­b\u001eÌÆJDKGÉøàôHáÖÔäJH9D\u0000\u000enH­ÄÊ)H\u0000\bÌLÆÝ\büKGÉøàôHáÖÔôJH9D\u0000­\u000enHÄJ)H\u0000\bÌLÆÝ\bül$hSËðH!È\b1§­D\u0000\u000e~¦¤|ì>!Æ\t\f\u0000écDé¬è0ê\­u0018?\b)(Êâ¦14\nJ DÄ\u0000\bª\u0000\f!\nH\u0000h,^F\b)\b\n­ô¦1ü\nJH9æ…\u0000¾®\nxÅ\nÀI,ìt`|ÿH!È\b1D­\u0000\u000e~¦¤\n)×\u0018!ÆLÆJDèh¬Z?\b)\­b\nô¦1ü\nJH9f\n\u0000\bH\nH!\nH\u0000èG4­ÿR\b)\b\nô¦1"

    what does that mean? I've tried a ton of different commands to flash it, erasing flash afterwards, but it didn't work once.

  • wrong baud rate in Espruino IDE settings? default is 9600, you need 115200

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Got d1-mini clones and not able to flash them

Posted by Avatar for opichals @opichals