• This is likely a very local issue with my environment, just chucking it out to see if anyone else has had it.
    I am running Chromium on OSX and my Web BLE connects reliably if I have just restarted BangleJS. After that, I deploy an App, run the app, then want to make tweaks, so I commit change to Github, hit refresh on the github.io page for my Apps, and the connection is lost. So far so good. Now when I say pair again, it hardly ever connects to BangleJS the second time (the device isn't listed as available in the pairing window). This is irrespective of whether I have crashed my app or not.

    I have to go into the Setup app, turn Bangle off, turn it back on, and it detects and connects again.

    Again, very likely, a local environment issue, but has anyone else encountered this out in the wild?

    I'll test on Raspberry Pi later and see if I have the same issue. Could just be my Chromium build.

  • Do you have HID enabled in settings? I guess it's possible that the Mac pairs with Bangle.js but then stays paired even after you disconnect because it then thinks it's a keyboard.

    Maybe also check BLE and Programmable are set to On?

    Also, what happens if you connect with the Web IDE? Does it say 'Connected, no response from the board', or can you just not see Bangle.js at all in the pairing window?

  • Ever since I wrote this post, connection has been stable and Chromium has been able to find the watch on request. :D :D :D

    @Gordon to answer you question
    Earlier, it wouldn't find the watch in Chromium's BLE connection dialog (until reboot).

    Currently I have the Programmable: On, Bluetooth: On and HID: off.

    (in other news I have now called storage.eraseAll() once and have (since) managed to revive my Bangle :D...)

  • Okay, though I marked it resolved, it is still a bit flaky but I've found two tricks

    1. Keep the WebIDE connected on one browser tab, and use the other browser tab to upload from Github then even if you do a hard refresh, the Connect button will still show the Bangle watch because the WebIDE is paired in the other window

    2. If Web BLE (Chrome fails to find your watch and connect) Go to "Make connectable" setting on Bangle's Setting app, select "no" and press middle button (BTN2). Then select "Make connectable" again and set it back to "yes" and press middle button. This avoids a reboot.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[Resolved] Having to turn off my BangleJS KS Beta unit, and turn back on ever so often to be able to connect with Web IDE or app loader

Posted by Avatar for PiOfThings @PiOfThings