Using the Web IDE from Raspberry Pi

Posted on
Page
of 2
Prev
/ 2
  • Glad it's working! Honestly, I haven't seen the no name issue here at all - which seems odd because the code on the Pi should be identical.

    However in the screenshot you have, one of the devices is definitely configured to be an Eddystone beacon, which would absolutely be your problem as Eddystone devices don't output names.

  • Thanks Gordon. Hadn't realised that about Eddystone.

    I suspect the issues were a mix of user error and the start.sh script not updating the names displayed. When it refreshes, it spots new devices ok, but doesn't seem to switch from "?" to actual name (e.g. when I tried NRF.SetAdvertising to try and force a name whilst trying to figure out what was going wrong).

    Still not sure why the Pi and Windows with Bluetooth polyfill were showing hex ids instead of names.

    So maybe a bunch of red herrings.

    It's fantastic to have this now. All my Windows issues are a thing of the past!

  • It's odd - supposedly EspruinoHub should keep updating the name if it ever receives an advertising packet with localName in it: https://github.com/espruino/EspruinoHub/¬≠blob/master/lib/discovery.js#L66

    I guess you could try adding some debug info and seeing what's actually in peripheral.advertisement?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Using the Web IDE from Raspberry Pi

Posted by Avatar for Pi @Pi

Actions