Flat battery in new pucks?

Posted on
  • Hi, I've just received my 2 pucks. Super-excited, but they don't appear to be working unless I'm doing something wrong.

    I've enabled web bluetooth and the Puck.js website has recognised this, but when I try to connect it can't find either of the devices. I've opened them and the batteries are already connected - no tab to remove. I've removed the battery, waited several seconds and put it back in. I didn't see any LEDs flash and it still doesn't appear on bluetooth. Could I have been sent pucks with flat batteries? Or some other problem?

  • I'm pretty sure there is a tab in there between the battery and PCB, but it's clear plastic and cut down to the length of the PCB, so it's really easy to miss.

    Best way to tell if it's working is to take the battery out, then put it back in with the button held down. The green led should light up, and if you keep the button pressed for around 3 secs all 3 leds will light. If you then release it, the green led should flash and few times, indicating the self test has passed.

  • You're absolutely right. I was expecting something attached to the battery and didn't spot the clear tab against the PCB. We're up and running! Thanks :-)

  • I'd suggest it is the tab you need to remove. I only knew it was there since I'd heard @Gordon mention it previously. It's a fiddle to get hold of though mine was inset into the PCB not flush with the side so there's not much to get hold of - I had to take the battery out, remove the tab and refit. No big deal, but a bit of an overhang would be better.

    @Gordon, they're very nicely put together and packaged. Very pleased with them, lots of potential.

  • Thanks! Yeah, I'd hoped the tag would stick out and around the side, but it's quite thick and I think the people assembling it all found that they couldn't put it all together if the tag stuck out too much.

  • I have tried what Gordon recommended and all LEDs flash but then I get the red flash alone and not the green one. Is something amiss? I cannot get my Mac to see it all.

  • You're probably not releasing the button immediately after all the LEDs flash? It runs a self-test which requires you to lift the button, so if you keep it held it thinks the button is broken and flashes red.

    Can you check if your Mac actually has Bluetooth low energy? instructions here: http://www.imore.com/how-tell-if-your-ma­c-has-bluetooth-40

  • I've had to buy a dongle for my mac. Getting it to work is another thing, 'continuity tool' did all the command line stuff needed to switch my mac over from the internal BT chip to the dongle. Asus BT400 works a treat.

  • On my Mac I had to use a dongle too - do you have a link to the instructions you used?

    If you have the developer tools you can use something called 'Bluetooth Explorer', or according to this it may automatically switch over on reboot: http://apple.stackexchange.com/questions­/94402/force-os-x-to-use-bluetooth-dongl­e-instead-of-built-in-controller

  • I did this in conjunction with https://github.com/dokterdok/Continuity-­Activation-Tool/

    To force your system to use an external Bluetooth controller instead of the internal one, open Terminal and type:

    sudo nvram bluetoothHostControllerSwitchBehavior=al­ways
    then reboot. To revert to the default OS X behavior, type:

    sudo nvram -d bluetoothHostControllerSwitchBehavior

    You may need to turn off (or un-pair) Bluetooth accessories that are currently using your internal Bluetooth controller, as they can prevent the dongle from being detected by the Continuity Activation Tool.

    The end bit was key. turning off the bluetooth devices and then bluetooth, then firing it back up finally did it for me.

  • Great - thanks! I'll update the documentation to add that - it's probably pretty common.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Flat battery in new pucks?

Posted by Avatar for paulmasri @paulmasri