Web IDE problems?

Posted on
of 2
/ 2
  • I'm seeing some weird connectivity issues in Web IDE: namely, I have two computers and connecting and interacting with the same Puck.js unit is very laggy on the other and snappy on the other. Both computers Macbooks with same operating system versions, the other is from 2013 and the other is brand new (late 2018). They are physically in the same place so things like location or external interference should not have an effect in this case, I suppose. The annoying thing is that the new computer, my main workstation, is the slower one.

    Sending a relatively simple ~100 line javascript file to Puck has so far taken as long as I have written this message, that is about 5 minutes, while it's more like half a minute with the other machine. Moreover, the BLE connection drops every now and then with the new computer. Haven't had any other BL problems with the system.

    Any thoughts?

  • Sun 2019.01.27

    Hi @massive please take the following comment lightly;   I'm glad to see someone else has made similar if not the same observations.

    In my case, uploading 'sending' code gets progressively longer (initial ten-fifteen seconds to later over a minute) in duration until after five-twenty times in total delay frustration, I have to dis-connect, close and re-launch the IDE to continue.

    'Sending a relatively simple ~100 line javascript file to Puck has so far ... , that is about 5 minutes'

    Are your issues similar to what I went through, and still go through, since five months ago?
    Can the assumption be made that you are not uploading locally developed modules?

    from #1 http://forum.espruino.com/conversations/­324495/   #1

    'At times, during a code upload, the 'Sending' green progress bar doesn't always go far right, so I'm never sure if the code actually uploaded.'


    from #8 http://forum.espruino.com/conversations/­325378/   #8

    'I had (perhaps wrongly) assumed that a computer from the last 10 years might be able to retrieve a file from the hard disk in under a quarter of a second'

    We have different OS's
    I experienced the same with any device, including the Puck
    Same app WebIDE - Or are you launching/running the website IDE? https://www.espruino.com/ide/

    Are you able to add to this list?

    What you might try:

    'the BLE connection drops every now and then'

    How much development (in days) has been done or how long have the Puck devices been left on? Are the batteries removed after each development session? Have you tried using a fresh battery?

    This might be of some help, are you running a virus checker and if so, does temporarily disabling it, allow the upload to occur?

    In my case, the upload then occurs, but the progressive delay in uploading is still present.

    What WebIDE version are you running? IDE >> Settings >> About

    What version of Espruino is currently flashed to the Puck? e.g. Have you flashed the most current?

    Would you please post the results of running: process.env
    so that Gordon has a bit more to go on and will save in exchanges speeding an answer for you.

  • @Robin I don't believe your previous problems with the Pico and with file loading from projects have any relation to @massive's issue - he's not using USB or Projects. I believe I also fixed the issue you had with the Pico months ago.

    @massive as Robin says if you're getting Bluetooth disconnects it's definitely worth checking your battery - when you get a connection you can try Puck.getBatteryPercentage() which should return a number from 0 to 100. Anything below about 40 and you're on borrowed time.

    You could also try using the latest firmware (2v01 at the time of writing). 2v00 implemented some power saving functionality that detected a lack of usage and slowed down the connection to save power, however I noticed that on some computer/ide versions the transmission was slow enough that it wasn't able to kick the Puck back into a high-power mode. Version 2v01 is much more sensitive and has really improved that.

    You could try running the command NRF.setConnectionInterval(7.5) on the Puck and see if that helps (it'll disable any power saving and will swap straight to the high power mode)

    Another potential issue is that most computers share the aerial for WiFi and Bluetooth. While it's not normally an issue, if you have loads of WiFi traffic that could interfere with Bluetooth?

    For instance I did a presentation where I had to mirror my whole screen onto the projector over WiFi. While doing that the communications over Bluetooth was slow and unreliable, but the second I stopped streaming it was fine even though WiFi was still enabled.

  • Hi, thanks for the your answers and sorry about the delay in answering.

    I'm using Web IDE, downloaded very recently from Chrome Web Store, namely version 0.70.6. Before that I used the Online web version. The puck is updated to most recent firmware I could find, 2v01.13, but the issue occurred with the previous one I had too; which I think was 2v00. I also tried to use Node-based version, but nw.js failed to install on my RasPi3b+, but that's another story I suppose.

    Battery shouldn't be an issue; it's currently at 96%. I also doubt that it is the culprit since the other computer is able to interact with the same Puck with same battery just fine. The same applies to WiFi interference; even though I'm not an expert, I would assume that it isn't the problem as another computer located literally next to the other works correctly.

    Basically the only thing which is different with the two computers is that the slower one has newer hardware. I'm in the same location, using same Puck with same battery, so I would (perhaps naively?) rule WiFi and battery out.

    I just had a several disconnections and very slow echo when I tried to get the battery percentage from Puck by typing the commands to the console.

    I haven't had time yet to try setConnectionInterval but will do so soon and report back to you.

  • Well, well, well. As an engineer I should've thought this before asking, but good old "have you tried turning it off and on again" helped. Merely restarting Chrome did not do the trick, but restarting the MacOS worked. Now, everything's fast even on the new laptop. Sorry about the trouble.

  • Great - thanks for letting us know! It's a good one for me to remember if anyone else has this issue :)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Web IDE problems?

Posted by Avatar for Gordon @Gordon