IDE - unusable!!!

Posted on
  • I love the Espruion and HATE the IDE it just sucks at times.
    The console says it's connected but locked I can't download.
    I re-booted countless times, uninstalled IDE from Chrome
    Re-installed the USB driver
    I'm at my wits end.

    I'm running win7 pro
    Any help greatly received

  • Has it just started doing this for you?

    • Is Espruino in 'bootloader mode'? The LEDs on it will be glowing on and off if it is.
    • Do you have another device plugged in that you might be connecting to instead?
    • Might you have reset/unplugged Espruino without clicking the disconnect button in the Web IDE? If so you'll have to make sure you completely exit and restart Chrome. It's a longstanding bug in Chrome that they've only just fixed - but it won't make it into normal builds for another month or so.
  • @Gordon it's just started working again for a reason I can't see.
    I've been using IDE every day for last 2 weeks, I always disconnect.

    One issue is the IDE won't reconnect so what I have to do
    is remove USB from pico
    Connect on IDE
    Reconnect USB to pico
    Select given port & then all works

  • Ahh right, so:


    1. Physically disconnect
    2. Physically reconnect
    3. Disconnect and reconnect via the button and no device appears


    1. Physically disconnect
    2. Click disconnect button
    3. Physically reconnect
    4. Click connect button
    5. Device Appears

    This is definitely the issue with Chrome Serial. It was reported over a year ago - I just tested with the Chrome Canary (one of their latest builds) and it's still not fixed I'm afraid.

    Do you think it's possible that you have a dodgy connection to the Pico? If it disconnected and reconnected, it'd explain all the trouble you're having?

    You might find that putting a sticky label or bit of tape on the back of the Pico's connector will increase the width and make it more reliable.

  • Hmm, I can unplug and plug the Espruino back in while it things it's connected, and it works fine - I just reconnect after plugging the board back in and it just works. It also notices when I unplug it, and the IDE automatically goes over to "disconnected".

  • Interesting - is that a'normal' version of Chrome, and on Windows 7? 64 bit?

    Seems odd the behaviour is different between computers.

  • Win 10, normal chrome, 64 bit.

  • Maybe they fixed it in Windows 10? Did you have to install drivers?

  • I'm pretty sure I had to install the usual ST drivers, but not 100% sure. I don't remember having to jump through any particular hoops.

  • @Gordon thanks for the tips

  • What the reason to use Canary vs Chrome? Canary - afaik - is used for Android development to have debugger and logger available on dev machine of any OS and runtime in Chrome on Android device.

    @LawrenceGrif, I experienced some blocking as well... I felt that when Espruino is busy 'like crazy', it just does not respond 'quickly' enough to communication coming from IDE (console or upload).

  • I thought Canary was just a more 'cutting edge' build of Chrome - more features, newer, but potentially more bugs. I'm sure I've done Android debug with normal Chrome - but I'm sure at some point in the past it was only available on Canary?

  • Android Chrome runtime debug in PC/Linux Chrome? - Chrome has Android (device) Chrome emulation... Specific to Canary was that Android's Chrome runs but it's debugger shows on PC/Linux Canary - when Android device is connected on USB - like Java VM remote debug.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

IDE - unusable!!!

Posted by Avatar for LawrenceGrif @LawrenceGrif