STMicroelectronics Virtual COM port (Code 10)

Posted on
  • Hey all
    I am running windows 7 64 bit. I am having a miserable time getting this com port to function. This is to flash the HY32_32 through the Demonstrator GUI. Thank you.

  • If you get STMicroelectronics Virtual COM port I guess it means you managed to flash the firmware on it properly - does it say 'Espruino' on the LCD display?

    The error you're getting is probably because Windows needs drivers for the COM port. I thought Windows 7 was fine, but maybe 64 bit isn't. Try following the Windows 8 instructions on this page and see if it helps...

  • Tried that a few times. I had it working a few weeks ago but it took me a day and a half to find some driver file that happened to work. Then my 3D printer showed up and I wanted to reset the windows computer to its factory state to get all the slow BS off of it. (my normal computer is a Chromebook) I sure wish I saved that file first because I can not duplicate whatever I did. Pulling my hair out! Its a HP laptop with Windows 7. Few years old..... Trying to re-flash with the network drivers.......

  • I had a lot of issue getting the drivers to work on windows 7 64. Even now the IDE does not show debug output but at least I can push to the espruino.

    Use the instructions Gordon has supplied - however you will have to go in to device manager and access the "drivers" tab for the unknown com device and manually point to the file that is unzipped with the driver download, it was greyed out for me when I tried to update drivers via the "devices and printers" window.

  • Guys can someone please post a YouTube video from the ground up on either Windows 7 or 8. I do now know what I am missing and this is just getting aggravating. I have tried 3 different computers. I have installed windows 8 dpinst_amd64.exe. Connected on the top left of the HY32. In boot mode. Thanks

  • Did you manage to flash Espruino onto the board? There are instructions here:

    If you can't flash Espruino, the problem is probably that the board you have uses a fake Prolific PL2303 chip for USB. Prolific got fed up with all the clones of their chip, and tweaked their drivers so that they don't support it.

    Just type pl2303 windows 7 problem into google and you'll get a bunch of suggestions from people with similar problems.

    Or... you could get one of the official boards, which 'just work', and help to pay for my work on improving and supporting Espruino :)

  • Yeah I have I think 14 Picos and one original. I have an application for these larger touch screens though. Thanks

  • Did you get it working in the end? if you found a good URL for the driver I can stick it into the instructions.

  • Yeah I finally got it to work. There are a few issues I had. On these boards I had to use the TOP RIGHT usb port. When I downloaded the ST Flash Loader Demonstrator I was trying to get the STMicroelectronics com driver to work and it did not at all. The driver that worked best for me was this Prolific Driver. Its a Prolific Driver Version and is dated at 7/31/2007

    You have to manually update the Driver. Similar to this video

    although after that driver was installed on my Windows 7 computer it was named plainly as "USB-to-Serial" until I re-updated the Driver.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

STMicroelectronics Virtual COM port (Code 10)

Posted by Avatar for Cale @Cale