• I've always had issues when I attempt to connect to serialports on Ubuntu. I can temporary get by when I execute: sudo chown :rich /dev/ttyACM0

    However, that gets annoying when I have to resubmit that command in the terminal. I tried to add the user rich to the dialout group, logout and log back into my account; however, I still get the Connection error when I attempt to connect to /dev/ttyACM0 How can I get the Espruino chrome app to gain access to /dev/ttyACM0 without having to execute the chown command?

  • Try this, and chance GROUP="your name".
    It works for me.

    1 Attachment

  • There's a udev rule that you can copy in to /etc/udev/rules.d/ that might help: https://github.com/espruino/Espruino/blo­b/master/misc/45-espruino.rules

    It'll make sure that the board is in 'plugdev', which I think your user is in by default.

    I still have an error connecting sometimes, but it usually resolves itself if I try again after 30 seconds or so. Looking at the command history on Espruino it looks as if some service in Ubuntu is trying to talk to it as if it's a modem.

  • @Frida beat me to it :)

  • Why can't i connect via terminal?

    espruino -p /dev/ttyACM0

    Espruino Command-line Tool 0.0.36

    Connecting to '/dev/ttyACM0'
    Port "/dev/ttyACM0" not found
    Unable to connect!

    The WebIDE works without a problem.

  • If i install the the espruino module local and not global it works:

    :~/Downloads/espruino$ node node_modules/espruino/bin/espruino-cli.j­s 
    Espruino Command-line Tool 0.0.36
    Using first port, {"path":"/dev/ttyACM0","usb":[1155,22336­],"description":"Espruino board"}
    Connecting to '/dev/ttyACM0'
              |_| http://espruino.com
     1v95 Copyright 2017 G.Williams
  • It's likely you have a permissions problem when trying to install globally, and the node-serialport library isn't able to be installed. Check out to see if you get any errors when doing npm install

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Connection error when attempting to connect to /dev/ttyACM0 on Ubuntu v14

Posted by Avatar for d0773d @d0773d