You are reading a single comment by @DEADh and its replies. Click here to read the full conversation.
  • Hello,

    I was really happy to receive my Espruino today :) , so I quickly wanted to try playing with it. However, despite of my efforts, it seems it is not working ... so frustrating ! Here is the detail of what I tried.

    • using an old iMac, still using Snow Leopard.
    • connecting the Espruino through the USB cable coming from my Sony phone, so cable is working properly (using it regularly for charging / USB Mass Storage and so on). When connecting, the blue + red leds both blink quickly once.
    • Mac OS X popups a dialog box, indicating new network interface was detected, "STM32 Virtual COM Port". Is it logical ? It asks to setup it (networking, as a modem setup ...), or Cancel. What to do here ? If I want to setup, it offers modem like settings (phone number, and so on, tried various ones without any success).
    • then I tried in console:
      ls /dev/tty.*
    • in Arduino Web IDE, I also see a corresponding entry, cu.usbmobem5d11 (?), but I selected the TTY one anyway.
    • clicking Connect displays "Connected", but pushing code to the device seems to not execute anything. Also, I did not get any message about firmware update ?
    • tried again with screen in console, no result / no prompt / nothing.
    • Finally I tried to flash. Rev 1.3b, so I had to manually select:Ā­o_1v48_espruino_1r3.bin
      (is it the correct one ? no 1r3b ?)
    • pushing buttons worked properly, the blue led is slowly moving. Web IDE displays "Initalizing", then almost directly "Error Flashing.".
      So I really suppose something needs to be setup first ? (probably around STM32 Virtual COM Port, but how to do it ?).

Avatar for DEADh @DEADh started