cant connect / error flashing

Posted on
  • Hello,

    I was really happy to receive my Espruino today :) , so I quickly wanted to try playing with it. However, despite of my efforts, it seems it is not working ... so frustrating ! Here is the detail of what I tried.

    • using an old iMac, still using Snow Leopard.
    • connecting the Espruino through the USB cable coming from my Sony phone, so cable is working properly (using it regularly for charging / USB Mass Storage and so on). When connecting, the blue + red leds both blink quickly once.
    • Mac OS X popups a dialog box, indicating new network interface was detected, "STM32 Virtual COM Port". Is it logical ? It asks to setup it (networking, as a modem setup ...), or Cancel. What to do here ? If I want to setup, it offers modem like settings (phone number, and so on, tried various ones without any success).
    • then I tried in console:
      ls /dev/tty.*
    • in Arduino Web IDE, I also see a corresponding entry, cu.usbmobem5d11 (?), but I selected the TTY one anyway.
    • clicking Connect displays "Connected", but pushing code to the device seems to not execute anything. Also, I did not get any message about firmware update ?
    • tried again with screen in console, no result / no prompt / nothing.
    • Finally I tried to flash. Rev 1.3b, so I had to manually select:Ā­o_1v48_espruino_1r3.bin
      (is it the correct one ? no 1r3b ?)
    • pushing buttons worked properly, the blue led is slowly moving. Web IDE displays "Initalizing", then almost directly "Error Flashing.".
      So I really suppose something needs to be setup first ? (probably around STM32 Virtual COM Port, but how to do it ?).
  • It looks good that you're connected and you see those devices in the Web IDE.

    When it says 'connected' in the Espruino Web IDE, if you click on the black area and just type some text, does anything appear?

    I think you need to cancel the dialog box asking about network interfaces. I don't know what happens once it is configured to be used as a modem, but you need to make sure that MacOS isn't trying to use the device (it may be that MacOS is already using it, and that's why the Web IDE can't sent/receive characters).

  • No, typing does not print anything in the IDE console. :(

    I clicked the Cancel button, but it does not change anything.

    I also think that there is some kind of conflict (perheaps becaus of old devices that I used some years ago ?), but I don't see where I can disable/uninstall something which would be related to USB/COM ...

  • Is there anything to do with Modems and dial-up networking? That's likely to be the issue.

    Can you try the board on another computer just to rule that out?

  • I just tried connecting it to my (rooted) Transformer Prime (Android tablet), used Optware's screen, and the Espruino is working properly ! :) So it confirms my problem is on the Mac side, though I still don't understand why and this is annoying ... :( (would be much more practical for developing, upgrading firmware, and so on).

  • Great! Glad the board is ok...

    I'll see if I can find anything on it though. Other people must have had this problem (specifically newer Arduinos and the Leaf Labs Maple - as they appear as usbmodem devices too).

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

cant connect / error flashing

Posted by Avatar for DEADh @DEADh