• I decided to update the firmware from v2.10 to v2.13 this evening. When I connected my phone to the watch via nRF Toolbox as usual, I started the update. There was a failure. Every time I hit retry my phone reads '(number e.g. 3072) bytes were sent while 0 bytes were reported as recieved'.
    The watch eventually refreshes and reads BANK0 invalid.
    I can't reload the watch back to normal, so I keep retrying. The progress bar gradually fills up by a few millimetres every time I hit retry, so I keep going until the update is finished.
    I can no longer connect to anything via bluetooth. I have tried a factory reset, I've tried rolling back the firmware (no such luck). I can access the launcher and clock face, but as soon as I try and connect to the web IDE or the app loader from any computer in the house I get a prompt saying "disconnected".

    I look at the settings console in the web IDE and see

    BT> SEND ERROR: NotSupportedError: GATT operation failed for unknown reason.
    BT> Disconnected (gattserverdisconnected)
    Disconnect callback... {"port":"Bangle.js 75cd", "portName":"Bangle.js 75cd"}
    WARNING: [notify_warn] Disconnected from Bangle.js 75cd

    These past few weeks I've been working on a programming project for college using both Bangle.js models, the deadline is incoming and I've really hit a wall. The program is working perfectly but I need a working watch to download and present it.

    Is there anything I can do? Any help would be most greatly appreciated.