You are reading a single comment by @Gordon and its replies. Click here to read the full conversation.
  • That's likely your issue - that you get loads of data in on serial when you try and use I2C.

    If the line is high when Espruino starts it assumes Serial is on it and configures it. Best thing would be to change the serial pins in the build but if you manually set the pin modes to 'output' with pinMode first then it should disable serial

  • I've tried setting D6.pinMode('output') in E.setBootCode(), but it doesn't seem to have any effect.

    I also just tried removing the pins from boards/ and building firmware from source. Doesn't seem to have any effect either.

    Oh, and changing the pin physically would be my absolutely the last resort, since it's a custom PCB.


Avatar for Gordon @Gordon started