• @maze1980 - thanks for pointing that out. I removed all the console lines - and the same power consumption.

    @Robin - I tried checking all the pin modes - they don't seem to change. I used this code:

    console.log("A0 = ",getPinMode(A0));
    console.log("A1 = ",getPinMode(A1));
    console.log("A4 = ",getPinMode(A4));
    console.log("A5 = ",getPinMode(A5));
    console.log("A6 = ",getPinMode(A6));
    console.log("A7 = ",getPinMode(A7));
    console.log("B0 = ",getPinMode(B0));
    console.log("B1 = ",getPinMode(B1));
    console.log("B3 = ",getPinMode(B3));
    console.log("B4 = ",getPinMode(B4));
    console.log("B5 = ",getPinMode(B5));
    console.log("B6 = ",getPinMode(B6));
    console.log("B7 = ",getPinMode(B7));
    console.log("B8 = ",getPinMode(B8));
    console.log("B9 = ",getPinMode(B9));
    console.log("B10 = ",getPinMode(B10));
    console.log("B13 = ",getPinMode(B13));
    console.log("B14 = ",getPinMode(B14));

    And got this output:

    A0 =  analog
    A1 =  analog
    A4 =  analog
    A5 =  analog
    A6 =  analog
    A7 =  analog
    B0 =  analog
    B1 =  analog
    B3 =  analog
    B4 =  analog
    B5 =  analog
    B6 =  af_output
    B7 =  af_output
    B8 =  analog
    B9 =  analog
    B10 =  analog
    B13 =  analog
    B14 =  analog
  • Tue 2020.03.03

    @narath thank you for the validation and pin mode output as that will assist us all.

    'Interestingly, the Blue LED is now showing again'
    'I did download the latest edge firmware and flash it'

    Please post process.env for Gordon, thanks.

    Regarding pin mode. Now I'm a bit befuddled. In post #22 I was under the impression that it would be intentional to set A0 and A1 to 'pulldown' however the output is showing 'analog'.
    Was this done on immediate power-up with no code saved and just uploading the getPinMode() code snippet?

    Please see Gordon's comment in post #24 before setting all to a known state. Has that suggestion been tried? When done, please post pre and post pin mode output to verify none are changing.

    I wish I could find the post, (first read by me around three months ago - @allObjects was this one of yours?) that provided some insight as to setting to a known state, and the consequences that might result if not done. (even after chip power on to it's default state)

    EDIT Thr 2020.03.05:
    Found it!! But specifically for nRF and not STM
    At minimum, read post #15 thru post #17

    Also remember a comment, but I think pertained to USART port pins, about not leaving in a certain state as that left the oscillator on.   (still searching. . . . )   A S.W.A.G. hunch here, but in 'analog' mode, maybe related to PWM reads, possibly requiring that oscillator?

    Narath I know you are extremely detailed and vigilant, but is there a chance something else has changed in the setup? Originally, I started to think that the flash process disconnected the battery-resistor test circuit, and this was cured by that (thumbs up image) task. But, as has been indicated, other things changed, such as code line clean-up and technique etc.


Avatar for Robin @Robin started