• @gordon Nothing changes.
    1) I had it working perfectly at home.
    2) Went to work (and did "throw" it into my backpack. but it looks fine
    3) tried to connect it to my phone wifi. and it started giving the error. Tried work's wifi same error
    4) Got home (said maybe there's something it likes about home) Same error (no 'reset')
    4a) tried reapplying the solder iron to make sure everything was well connected and I hadn't moved it away.
    5) went to the convention (no password on the wifi). Didn't work
    6) Tried a bunch of different options. debugging debugging. BLAM it starts working. Try it again. still working. "save()"
    7) turn it off and on again. NOPE.
    8) and I cannot get it to work.

    I tried lightly pushing it to see if it was slightly off. No good.

    @Robin - This is the "new" badget, not the pixl.js with a wifi shield. (I didn't get to that since I was still trying what should have worked)

    @allObjects I can try what you suggested with the capasitors. but haven't had a minute to do it.

  • Sat 2019.12.07

    Geez @Damian that must have been quite a "throw" ;-)

    It is most unfortunate that the electron God's are not with us on this one. It has been quite a while since I have seen such sticky troubleshooting required like this in an electronic device.

    Confirming: So that we are all on the same page, by "new" badge we are referring to the first Nodeconf badge with the new 8266 soldered in attached to a WiFi shield? (rules out the under sized regulator path)

    Does removing the WiFI shield allow any code at all to run reliably?

    'Got home (said maybe there's something it likes about home)'

    Maybe it's the thought of actually 'having to go to work' ;-)

    '4a) tried reapplying the solder iron'

    I checked the images from post #14 and a very nice solder job (solder flowed and shiny) there, so it most likely isn't a cause, but was smart to at least consider and try.

    'Try it again. still working. "save()"'

    Could it be in the way the init function is called when using save()? Would you mind posting the few lines of code section for E.on('init'


Avatar for Robin @Robin started