• NOTE: I solved this issue by using a Windows 7 box, and am only posting this here in case it helps to troubleshoot the specific issue I saw.

    I'm running ElementaryOS (linux) and was running the Espruino Web IDE via the Chrome plugin installed in Falcon (a slight variation built on top of Chrome).

    I was able to connect to the Espruino WiFi board with no issues when in standard mode... could save programs to the board, make lights flash, etc. The issue came when I tried to flash the latest firmware (my board came with v1.91, was trying to update to 2v04. Per the instructions in the IDE I disconnected the USB, held down the reset button, reconnected USB, let go of button, and the board successfully entered bootloader mode ( red and green lights flashing). When I then tried to reconnect via the IDE it reported that it could not connect. I repeated this process multiple times with no joy.

    I then switched over to the Windows 7 box, installed the IDE in vanilla Chrome, connected, ran a program, and followed the same instructions above to enter bootloader and flash the firmware. Had no problems at all.

    Again, I only offer it here in case it helps future development in supporting Linux systems. The next time I see there is a firmware update I'll try it from the Linux box again and report back if the problem is solved or not.

    Thanks... great board, love the low barrier to entry... nice work!

  • Hi,

    Glad you got it sorted in the end!

    Had you installed the udev rules mentioned here? http://www.espruino.com/Quick+Start+USB#­plugging-in

    I think without them, Linux can start thinking your Espruino is a modem, and it'll 'claim' it and try and send modem commands to it. Generally after 5 minutes or so it'll give up and you might be able to use it, but udev rules are the better solution :)

  • Thanks Gordon... I did add the udev rules and was able to confirm my user via 'groups' before I connected the first time.

  • Wow, that's strange then. I actually do all my development on a variety of Linux machines (mainly Mint 19.1 - so also Ubuntu based) and haven't had any troubles, so I wonder what's different.

    Does anyone else have this problem?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Linux Unable to Connect to Espruino WiFi board when in Bootloader

Posted by Avatar for miscon02 @miscon02