espruino win10 ide problem with puck.js

Posted on
  • i have buy a new espruino puck but when upload a some code with the web ide, return me an error message in screen shoot

    2 Attachments

    • 1.png
    • 2.png
  • Hi Antonio - you Tweeted me as well? Did you follow what I said in the tweet?

    Hi Antonio, please can you have a look at­art … - specifically you need the 'Native IDE' on Windows, you need to pair Puck.js with Windows first, and it should appear as a menu item that actually says 'Puck.js'. COMx ports are USB.

    The page says:

    Bluetooth LE devices like Puck.js are not treated as serial port devices by Windows. If the IDE's connection menu shows devices beginning with the word COM (eg. COM5), they are not your Puck.js and connecting to them won't work.

    So if you're connecting to COM7, then that won't be helping.


    • Are you sure you're using the Native IDE?
    • Have you paired from the Windows Bluetooth Menu?
  • Hi
    I'Dont have a Blutooth BLE adapter, thinking this Puck.js are connectable directly with my usb-usart adapter......this adapter is COM7 in screen shoot
    For IDE I have downloaded the native trough­ive-application

    Wath can i do?


  • That makes more sense!

    Yes, the Puck should be connectable. Have you wired it up as in:­onsole

    You need to apply power to Puck.js after wiring up the USB serial adaptor, so it detects that Serial is connected at power-on.

    Also, if you have been using the IDE for other things (ESP8266?) you need to ensure the baud rate in settings is at the default value of 9600.

  • And that text that is echoed back to the console - it makes it seem like for some reason the TX and RX pins are shorted?

  • Ok Gordon
    The problem was inverted the pin RX and TX of my USB-Serial Adapter .
    Thank You So Much!

  • Great! Glad it's working!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

espruino win10 ide problem with puck.js

Posted by Avatar for AntonioRiccelli @AntonioRiccelli