• I have flashed many fitness trackers with an NRF52832 with a generic Espruino build with great success, but my last attempt is not working. I use OpenOCD to flash, and it seems to work just fine, flash, verify, reset, run (which I've done many times with other boards). But when I reset run, it's not advertising on BT. My board file does have that set as default console. I even tried flashing other builds for working devices (with other pins defined for BTN1) but no BT console. I know Espruino is running, as one firmware I flashed had defined D9 as input_pullup, which happens to be this new boards motor pin and it started humming right after reset. This is a fitness tracker from 2020, not available any more, but similar to the F07 and B5 which have working firmware available (thanks to @fanoush).

    The only difference I can see is that this seems to have a ceramic antenna, unlike the standard copper wire most others have.

    any thoughts or ideas appreciated!

    1 Attachment

  • you do have the MTU 53 line in the board file but I don't see matching linker setting like
    https://github.com/espruino/Espruino/blo­b/master/boards/BANGLEJS.py#L43 however the 2c40 is the default so that's probably not it https://github.com/espruino/Espruino/blo­b/master/targetlibs/nrf5x_12/nrf5x_linke­rs/linker_nrf52_ble_espruino.ld#L7
    when this is wrong softdevice fails at bluetooth initialization

    but if the very same binary works in other device then it is strange, what about mass erasing before flashing?

    and BTW if that D9 is BTN1 and you have bootloader too then the pullup can be set already by bootloader so main fw may not run

  • i'll fix the linker setting just to make sure, thank you. But yes I've tried working builds from other devices (just differnt BTN1) and they don't work either. I did a mass erase first, and from OpenOCD, everything looks perfect.
    I can try it without bootload, just flash app hex too.

    Thanks for the advice!

  • @fanoush The answer was: I fried something. I reflashed original FW and UICR and can see the HR lights activate to verify it's running (the screen was damaged while opening), but still no signal on nrfConnect.

    Update: I have a 2nd one.. just flashed that with the Espruino build, and it's perfect. So, issue resolved.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Flashing an NRF build to an NRF board works, but no bluetooth

Posted by Avatar for yngv126399 @yngv126399