• Hi!

    Today i've tested a firmware upgrade to the current firmware.
    I've downloaded espruino_2v04.99_banglejs.zip and flashed it succussfully to the watch.
    But after that, only the Default Watch does function.
    I cannot enter any menu or do something else.
    Also battery and bluetooth widgets are gone.
    I've upgraded every installed app to the newest version (which was possible) from https://banglejs.com/apps but still no luck.

    Also there are some errors on the watch after pressing some buttons.
    See screenshot.

    What should i do now?
    I've flashed multiple times with no errors, same result.

    1 Attachment

    • screen.JPG
  • Use Bangle.js https://banglejs.com/apps/

    • Tab About and
    • Set Bangle.JS Time to fix the GPS stuff.
    • use longpress BTN3 to reset

    Can you connect via WebIDE and share some details like process.env

      VERSION: "2v04.356",
      GIT_COMMIT: "3bd026c23",
      FLASH: 524288, SPIFLASH: 4194304, STORAGE: 1048576, RAM: 65536,
      SERIAL: "c7fa9624-75c07c51",
      CONSOLE: "Bluetooth",
      MODULES: "Flash,Storage,hea" ... "ow,graphical_menu",
      EXPTR: 536883676 }
  • Thanks for the hint with the "About" Tab. I've done 'Remove All apps' and 'Install default apps' and than 'Set BangleJs Time'.

    This fixed all issues for me.

  • perfect 👍🏻

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Firmware Upgrade espruino_2v04.99_banglejs.zip makes watch unusable

Posted by Avatar for BrainFooLong @BrainFooLong