HTTP requests causing system to crash and reboot

Posted on
  • Running Espruino 1v99.175 on an ESP32

    This is the same result when I try any of the simple HTTP request examples on the site.

    Guru Meditation Error: Core  0 panic'ed (LoadProhibited)
    . Exception was unhandled.
    Register dump:
    PC      : 0x40118821  PS      : 0x00060f30  A0      : 0x8013b053  A1      : 0x3ffdbec0
    A2      : 0x00000000  A3      : 0x0000414d  A4      : 0x3f40ffc0  A5      : 0x00000000
    A6      : 0x00000001  A7      : 0x00000000  A8      : 0x8011881f  A9      : 0x3ffdbea0
    A10     : 0xfffffff0  A11     : 0x00000000  A12     : 0x00000001  A13     : 0x00000a8c
    A14     : 0x00000000  A15     : 0x00000416  SAR     : 0x0000001e  EXCCAUSE: 0x0000001c
    EXCVADDR: 0xfffffffe  LBEG    : 0x40096b78  LEND    : 0x40096ba6  LCOUNT  : 0x00000000
    Backtrace: 0x40118821:0x3ffdbec0 0x4013b050:0x3ffdbee0 0x4012be86:0x3ffdbf00 0x4012bfe5:0x3ffdbf30 0x4012d5f6:0x3ffdbf50 0x4012d873:0x3ffdc000 0x40151812:0x3ffdc0c0 0x40151837:0x3ffdc120 0x4011a6e7:0x3ffdc180 0x4011d5dd:0x3ffdc200 0x4011ba51:0x3ffdc340 0x4011bb45:0x3ffdc370 0x4011bc08:0x3ffdc390 0x4011bee7:0x3ffdc3b0 0x4011befb:0x3ffdc3d0 0x4011bf0b:0x3ffdc3f0 0x4011cac4:0x3ffdc410 0x4011d040:0x3ffdc430 0x4011d218:0x3ffdc450 0x4011db15:0x3ffdc470 0x4011ba51:0x3ffdc560 0x4011bb45:0x3ffdc590 0x4011bc08:0x3ffdc5b0 0x4011bee7:0x3ffdc5d0 0x4011befb:0x3ffdc5f0 0x4011bf0b:0x3ffdc610 0x4011cac4:0x3ffdc630 0x4011d040:0x3ffdc650 0x4011d218:0x3ffdc670 0x4011db15:0x3ffdc690 0x4011ba51:0x3ffdc780 0x4011bb45:0x3ffdc7b0 0x4011bc08:0x3ffdc7d0 0x4011bee7:0x3ffdc7f0 0x4011befb:0x3ffdc810 0x4011bf0b:0x3ffdc830 0x4011cac4:0x3ffdc850 0x4011d040:0x3ffdc870 0x4011d218:0x3ffdc890 0x4011db15:0x3ffdc8b0 0x4011eca2:0x3ffdc9a0 0x4014c94e:0x3ffdca00 0x4014caa4:0x3ffdca40 0x4014cad9:0x3ffdca70 0x4011a6e7:0x3ffdca90 0x4011d5dd:0x3ffdcb10 0x4011eca2:0x3ffdcc00 0x401206e8:0x3ffdcc60 0x40120c20:0x3ffdcc90 0x40120c80:0x3ffdccd0 0x401223de:0x3ffdccf0
    ets Jun  8 2016 00:22:57
    rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    mode:DIO, clock div:2
    entry 0x40078c4c
    WARNING: has simple connection not implemented yet
    Loading 15996 bytes from flash...
    Running onInit()...
  • Interesting... of course annoying for you...

    What about the power supply? Unstable power supply can cause reboot.

    Browsing the Web bubbled this 6+ months old thing up:­Mesh/issues/221

    It's not core 0 but core 1 and it's not Espruino but Arduino... nevertheless it is a thought worth. @JumJum has done quite some work on ESP32 and things may ring a bell for him...

  • Did you turn off bluetooth? It frees up some resources on that version particularly.



  • I tried v1.98 which works fine and v2.0 and up work although there is an issue with the WiFi module saying

    ERROR: Wifi: event_handler STA_START: esp_wifi_connect: 12298(SSID is invalid)
    WARNING: Wifi:startMDNS - espressif

    Although the connection is in fact successful

    I'm using v1.98 for now because it doesn't crash on requests and doesn't have this WiFi issue.

  • How do you use that? I get an error.

  • It showed up only recently, but probably is in 1v99 for sure:

    ESP32.enableBLE ⇒
    Call type:
    enable - switches Bluetooth on or off
    Switches Bluetooth off/on, removes saved code from Flash, resets the board, and on restart creates jsVars depending on available heap (actual additional 1800)
    Note: This is only available in devices with Bluetooth LE capability
  • Tue 2019.07.16

    Gordon wrote this nifty trick on how to check an addition in a different post a while back. If one clicks on the right facing arrow, adjacent to the heading ESP32.enableBLE at:­2_enableBLE

    which hyperlinks to the GitHub source, L123­b/master/targets/esp32/jswrap_esp32.c#L1­23

    That file edit date is 46eceda on Jun 8, 2018

    Now if I could only find the chronological running edit detail for versioning . . .

    EDIT: Ahhhh . . . here it is:­eases

    1V99 was on on May 22, 2018

    Not definitive, as I'm not sure if one can fetch data on older releases to determine the actual inclusion date, short of d/l the referenced .zip and doing a lookup that way, or running through each pull request.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

HTTP requests causing system to crash and reboot

Posted by Avatar for espftw @espftw