You are reading a single comment by @Robin and its replies. Click here to read the full conversation.
  • The USB cable is perfectly intact, the pogo pins are free and there's nothing on the pads at all.

    The LED is still just flashing irregularly and very fast, but nothing else is happening. I tried all the different combos again and it's just as lifeless.

    I've tried charging it directly from my laptop and now it's been sitting on a high power USB mains plug for a few hours. I know the plug is fine because I use it for my phone.

    This is normally where I'd re-flash the firmware, but I don't think it's simple (or possible?) to flash them without the OTA part working. I know it's a beta version, so I'm not expecting it to be 100% right away. Hopefully someone will have a winning idea soon.

  • As there is an indication of activity with the flashing LED, then by now there should be sufficient charge to attempt the following. I had to do this five times before the screen came to life.

    What exactly happens while viewing the screen, when (top - between N and E) BTN1 and BTN2 are held in for a full six seconds, and then releasing just the BTN2 middle button, keeping BTN1 held in for another six seconds before finally releasing that?


Avatar for Robin @Robin started