• Hi, I am trying to install Espruino on stm32f100 chip and use it in my DIY nixie clock project. I found that STM32VLDISCOVERY board is based on the exact same chip. I used it's firmware and flashed it on my chip using JTAG programmer (made from a raspberry pi + openOCD). The programmer says that the firmware is flashed successfully, but when I connect to the chip's uart with minicom -o -b 9600 -D /dev/ttyAMA0 i get nothing. There is no Espruino console.

    Here is how my wiring looks like:

    Here is what I had tried:
    1) Checked my wiring (I tried it in multiple ways. I also tried to connect to my MacBook using USB-TTL dongle, I can see the dongle from Espruino ide, but it cannot connect to the chip)
    2) I followed this forum post
    3) I made a custom build based on STM32VLDISCOVERY and changed the package to LQFP48 to match my chip

    I also found some weird behavior.
    In boards/STM32VLDISCOVERY.py in devices section, there are JTAG pins defined

    'JTAG' : {
            'pin_MS' : 'A13',
            'pin_CK' : 'A14',
            'pin_DI' : 'A15'

    But after flashing the programmer can't connect to the chip again without "connect under reset" procedure, which means that this pins have been overwritten.

    Any clues will be appreciated


Avatar for George @George started