The register is to set not only the time but a few other parameters as well. So I can write function to set time only, of course. It can get register, then add time and set the register back. But may be it is easier to users to look at the datasheet, isn't it? While the datasheet is not well-understandable, but I do not think adding separate functions or parameters with strange names makes it more understandable.
So may be it would be better to remove the names from the module. Please do that if you think it will be better in Espruino environment.
© Espruino, powered by microcosm.
Report a problem