It's the number of available 'Central' (eg. Espruino connecting to another device) links supported at one time - currently only 1 or 0 is supported - so yes, it's basically just GATT_CLIENT_ENABLED
"ifdef" : "NRF52,ESP32"
This sounds like a good plan - if there's something that could be common then I'd add new functions to bluetooth.h, but I think otherwise just having the ifdef inside jswrap_bluetooth.c isn't too bad.
different naming ... I wonder if there is a general naming convention.
I doubt it :) I guess to avoid as much confusion as possible I'd stick with the naming that's used for the JS APIs themselves - but I know that may not be the case at the moment :)
Espruino is a JavaScript interpreter for low-power Microcontrollers. This site is both a support community for Espruino and a place to share what you are working on.
Thanks - you too!
It's the number of available 'Central' (eg. Espruino connecting to another device) links supported at one time - currently only 1 or 0 is supported - so yes, it's basically just
GATT_CLIENT_ENABLED
This sounds like a good plan - if there's something that could be common then I'd add new functions to
bluetooth.h
, but I think otherwise just having theifdef
insidejswrap_bluetooth.c
isn't too bad.I doubt it :) I guess to avoid as much confusion as possible I'd stick with the naming that's used for the JS APIs themselves - but I know that may not be the case at the moment :)