• @Wilberforce - very cool - thanks for sharing !

    downoaded the zip file and stored the js files in the module folder

    running a ESP8266 with 1v89

    tried this

    var fs = new(require("FlashStoreWrite"))(0x7c000)­;
    var config={start:4, end:9, data:'fishing'};

    and got

    >WARNING: Module "FlashStore" not found
    WARNING: Module "FlashItem" not found
    Uncaught Error: Constructor should be a function, but is Object
     at line 1 col 83
     at line 1 col 2885
    ...(require('FlashStoreWrite'))(507904);­var config={start:4,end...

    Inside of FlashStoreWrite there are two require statements that seems to cause the Error.

    loading them separately works fine

    var FlashStore=require("FlashStore");
    var FlashItem=require("FlashItem");

    no Errors and no Warnings...

    @Wilberforce any idea why this is not working on my side ?

  • @MaBe
    I just tried and I'm getting the same as you - for some reason the FlashStore=require("FlashStore") module is not getting found.

    I'll look into it.


Avatar for MaBe @MaBe started