Espruino stopped working

Posted on
  • After compiling the linux version and running some tests locally, when I plugged the Espruino board in, /dev/ttyACM0 did not exist. After several retries, including RESET on Espruino, I noticed there was no output in dmesg. Changed the USB hub, still nothing.

    After a PC restart, this is the message I got in dmesg, but only the first time I plug the board in:

    [   70.487846] usb 3-2: new full-speed USB device number 5 using xhci_hcd
    [   70.487912] usb 3-2: Device not responding to set address.
    [   70.691909] usb 3-2: Device not responding to set address.
    [   70.896019] usb 3-2: device not accepting address 5, error -71

    Subsequent plugins do not output anything. Does this sound familiar to anyone? (i did not flash the board, other usb devices are working)

    Later edit: I added usbcore.old_scheme_first=1 to grub init, same thing, no dmesg output when plugging in. The cable works, tested with my phone.

    Later later edit: I tested with the Espruino board I got for a friend and it works :( So I guess mine is bricked ... somehow... no messages are output by dmesg anymore, not even after restart(s). I remember the red led flashing for a fraction of a second (very short time) when I plugged it in and I noticed it wasn't working.

  • There was a moment, when I was trying to flash my Espruino, that I thought I had bricked it. I had flashed the board and the firmware did not work. The lights would not turn on and the serial port would not initialize. Then I tried to set it into bootloader mode, but I found that doing so does not initialize the serial either, so I thought I was out of luck for reflashing my board.

    In the end, I held down button 1 and reset while unplugging and plugging in my board. Once the board was plugged in again, I released reset which put the board into BootLoader mode again, but this time the serial port was initialize and I could reflash it with the current good version of the firmware.

    Maybe a similar method will re-initialize the usb port and allow you to flash the firmware on your board to get it back into working state (yes, I know that you didn't flash the board initially, but it might not hurt to do so as a means of trying to fix it).

    Just an idea.

  • Hi, sorry it's not going... Did you try ask the things here?

    The first one is with trying as you'll be able to see if the board is getting power. Please can you try another USB cable anyway as well? Not sure why but a lot of people have had trouble and this board could just be 'on the edge'. The fact that Linux at least partially recognises it makes me think it's possible...

  • I did what cephdon suggested. Here's how it went:

    1. plug in, no output in dmesg, plug out, change cable, plug in, no output.
    2. hold RST then BTN1 pressed for ~1 sec, then plug out and release buttons
    3. plug in, I saw the red LED light up for a split second, dmesg said Device not responding to set address again.
    4. hold RST then BTN1 again for ~1 sec, then plug out and release buttons
    5. plug in, I saw the red LED light up for a split second again, dmesg shown proper registration as USB ACM device

    Thanks cephdon. I hope the steps I listed here help others and help debug :)

  • False alarm. I guess it worked for 1 second. Here is the dmesg output when I handled the operation described above:

    [30086.430599] usb 3-1: new full-speed USB device number 6 using xhci_hcd
    [30086.430724] usb 3-1: Device not responding to set address.
    [30086.634859] usb 3-1: Device not responding to set address.
    [30086.838994] usb 3-1: device not accepting address 6, error -71
    [30101.974199] usb 3-1: new full-speed USB device number 8 using xhci_hcd
    [30101.991363] usb 3-1: New USB device found, idVendor=0483, idProduct=5740
    [30101.991366] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [30101.991368] usb 3-1: Product: STM32 Virtual COM Port  
    [30101.991369] usb 3-1: Manufacturer: STMicroelectronics
    [30101.991370] usb 3-1: SerialNumber: 48DF62573330
    [30101.991480] usb 3-1: ep 0x82 - rounding interval to 1024 microframes, ep desc says 2040 microframes
    [30102.072469] cdc_acm 3-1:1.0: This device cannot do calls on its own. It is not a modem.
    [30102.072487] cdc_acm 3-1:1.0: ttyACM0: USB ACM device
    [30102.072735] usbcore: registered new interface driver cdc_acm
    [30102.072737] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
    [30102.146920] usb 3-1: USB disconnect, device number 8

    It disconnected without me unplugging it. Now there is no output, i retried the steps above. It does not look like it's dead, it still blinks the red led after resetting, but the logs are empty. I'll explore additional options tomorrow :(

  • Can you try the troubleshooting page and try and see if power is always connected? When in bootloader mode, some LEDs should always be lit up - so if they're not then something is wrong.

  • Keeping the RST button pressed helped debug the issue. The contact between the connector and the board needs resoldering or a complete change, looks rather tricky for my bulky soldering iron. I guess they are not as resistant as I had hoped, I only plugged/unplugged the cable a couple of times. I guess I'll speed up my USB extension cable purchase :)

    If anyone is curious: applying pressure on the back of the board's connector (on the margin that sits towards the inside of the board) makes it work.

  • @randunel, has the connector come unsoldered from the board, or has it pulled the tracks off the PCB? Could you e-mail me a picture?

  • I tracked it down to the slide on the edge towards the 10uF condenser. Just pressing it down a little but using a pen makes the board work. I am pointing to the disconnected slide in this photo.

    I took some photos using my phone since I don't have another camera. They are high res, but the phone's sensor is rather limited. Here's the link with the pictures, there is also an archive if you want to download all of them. Warning: large sized pictures.

  • Great, thanks! Looks to me like the USB connector has been placed a bit far off the board, and that it's not really soldered properly either.

    Can you send me an e-mail with your address in, and I'll send you another. Please could you send the old one back when you get the new one though? I can always resolder that and use it myself :)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Espruino stopped working

Posted by Avatar for randunel @randunel