Espruino Board will not connect anymore

Posted on
  • I have two Espruino Rev1.3b boards. I upgraded both of them to the latest FW. One connects and operates fine afterwards. The other will not connect anymore. It shows up as a VCOM port. It will go into bootloader with blinking blue led but will not connect in order to reflash. What can be done now?

  • Have you tried restarting your computer? What often happens is the Espruino gets reset (either unplugged or the reset button is pressed) while the Web IDE is still connected. This means that when the device is next plugged in, Windows is unable to connect it to the same port.

    Often Chrome keeps running in the background, so simply closing and re-opening the Web IDE won't fix it.

    Hopefully the situation will get a lot better when the next version of Chrome comes out and the Web IDE can actually detect when the device is unplugged. Until then, just remember to disconnect the Web IDE before unplugging the device.

  • Gordon,

    It was late and I decided to post and then I shutdown my computer for the evening.
    I received your comment this morning and have tried to connect. Everything is working fine! Thank you for all the work you have done and are doingwith this fine project. Looking forward to great things!


  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Espruino Board will not connect anymore

Posted by Avatar for TrapperBob @TrapperBob