'Module not found' when trying to load any module

Posted on
  • Hello,

    I just received my new Espruino Starter Kit a couple of days ago.

    When I tried to go through the tutorial on using the DS18B20 temperature sensor (http://www.espruino.com/DS18B20), I came across a weird problem: Apparently I can't load any modules. Here's what happens:

    ERROR: Unable to read file : NOT_READY
    WARNING: Module not found

    The same error also occurs when I try to load some other module from http://www.espruino.com/modules. The Modules/Config entry in the options is set to {"url":"http://www.espruino.com/modules","fileEx­tensions":[".min.js",".js"]} (which, I think, is the default value), and I am using Firmware version 1v48 and the Espruino Web IDE under MacOS.

    Any suggestions on what I might try to fix this?


  • Ahh, right - I think this is because you're typing code in the left-hand side and the Web IDE doesn't automatically look at what you type there and load the libraries - each character goes right to Espruino, so by the time you've hit enter on a command, it's too late to load the library.

    Your best bet is to simply type require("DS18B20") on the right-hand side and click thesend to espruino button. Then you can type on the left as you want.

    I'll update the DS18B20 docs to mention this...

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

'Module not found' when trying to load any module

Posted by Avatar for TheoryOfRain @TheoryOfRain