getting started (SOLVED)

Posted on
  • I just received the board and trying to update to the latest firmware. Following the instructions, when I hold down BTN1 and press RST, the blue LED does not 'glow'. Instead, the blue and red LEDs stay on. What am I doing wrong? I am on WIN7 but I don't think this matters since I cannot even get the board to a state it can receive the firmware. Please help!

  • Have fun with your Espruino :). When you hold down BTN1 and then press RST you indeed see the blue and red LED. Don't release BTN1 at this point. Only release RST. This should make the blue LED start glow while the red LED turns off. You can then release BTN1.

    To exit this bootloader mode just briefly hit the RST button.

  • Hi,

    Can you actually connect to your board via the Web IDE, enough that it tells you there is new firmware available?

    When you hold BTN1 and RST down, the blue and red lights should glow dimly, and when you lift RST (with BTN1 still down), the blue and red lights should light brightly until your board is connected via USB (then the blue LED will start pulsing).

    So what I'd guess is happening is that your board isn't managing to connect via USB. Can you check:

    • That you have disconnected (by pressing the stop button) in the Web IDE before resetting the board with the RST button
    • That you hold reset down for maybe 5 full seconds (just to be safe - windows sometimes takes a while to detect that the device has disconnected)
    • If the Web IDE doesn't tell you that you have new firmware when you first plug in the board, maybe try with a different USB cable (I've had a few reports of people using broken cables).

    Hope that helps!

  • The problem was in the cable. Thank you!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

getting started (SOLVED)

Posted by Avatar for muratgu @muratgu