Problems with the latest build on HY 3.2"

Posted on
  • Hello, I'm trying to update to the latest version of Espruino on HY-Mini and the flashing process goes fine - it verifies with no problems. But then windows says that this device reported problems and it's unavailable. Reinstalling windows drivers doesn't help but reverting back to Espruino 1v41 solves the problem immediately.
    Is that something to do with my system or with that particular build?

  • OK so I've tried again with different versions and this problem is 100% repeatable. All versions up to (an including) 1.43 are working fine but version 1.44 doesn't work.
    The exact error message is

    One of the USB devices attached to this computer has malfunctioned, and windows does not recognize it.

  • Hi,

    That's strange - could be the new USB drivers from ST. I've got to look at USB again anyway now though.

    Can't you just use the other USB port (the one you use to flash it?). If this fails then it's a problem with your PC, as the chip that provides USB for that is completely separate.

  • When I use other port - the one with Prolific driver - then I can connect to my board but terminal is unresponsive so I can't type anything and I'm not getting any feedback. With older Espruino versions this port works fine.

    I have also pinned it down to 2013-12-13 build. That's when problem starts. Build from the night before works fine and it also identifies itself as 1.44 but the file size and file name is different.

  • I tried this and fixed it yesterday - try the most recently nightly, it should be fixed.

    I recently moved F103 parts over to using the RTC to keep time, and there must be some issue with the initialisation on the HY board. I've gone back to using SysTick for now so they should work, but it'd be nice to swap everything over eventually:­ues/152

  • Just want to confirm that the latest build works. Thanks!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Problems with the latest build on HY 3.2"

Posted by Avatar for graf @graf