• So I had some trouble with updating from 2.16 to 2.21. After a few unsuccessful attempts with the App Loader (progress stopped at around 20%) and the infamous "storage corrupted" issue I resorted to updating via DFU and the nRF connect app. Well, that worked, but now booting stops at the boot screen after hanging at "checking storage ..." for a while.

    I am unable to turn the watch off, so I keep it connected to the charging cable, to spare the battery. Holding the button does work, I can enter DFU mode, but after multiple attempts at flashing different recent-ish versions I still get the same:

    1 Attachment

    • IMG_20240516_212818513.jpg
  • Hi - that Bangle.js screen is fine - it basically just means that there isn't any JS code on the watch for it to run.

    You could connect with the app loader and try backing up just in case there was anything left on the watch previously, then choose 'install default apps', but if you don't care about that and just want it to work:

    • Hold the button down for ~15 seconds - the watch should reboot, show ==== going across the screen, and should finally show a 'recovery menu'
    • From the recovery menu choose 'factory reset'

    and that's all you need

  • Thanks @Gordon, this trick did it!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle.js 2 botched upgrade, stuck on boot screen

Posted by Avatar for user158134 @user158134