• For context, I have a Google Pixel phone running Graphene OS.
    I would love to get the Camera Shutter App to work, but I just don't know how to make it work!

    My Bluetooth pairing is working normally for everything else... but do you all have any advice for successfully using the Camera Shutter app?
    Thanks!

    (EDIT to add: my phone has a volume rocker button, which when pressed, does take a picture. I believe the Shutter App on the bangle sends a trigger to the volume button or something like that. So, just for additional context... my volume button is already programmed to take a photo)

  • Did you see what it mentioned in the readme? https://banglejs.com/apps/?id=hidcam&rea¬≠dme

    Once you have set HID to "Keyboard & Media" in settings you'll have to repair with your phone, but then it should work well.

    If you have Gadgetbridge then it may be possible for the app to send an 'intent' to take a picture, but I'm not sure there is an existing app that does that yet

  • Thank you! I am using the Bangle Gadgetbridge specific app. The HID is set to Keyboard and Media. I just unpairing the device and repairing.... still not working. To take a picture, is it advisable to disconnect the Bangle from Gadgetbridge first? And have it paired only to my phone?

  • To take a picture, is it advisable to disconnect the Bangle from Gadgetbridge first? And have it paired only to my phone?

    It shouldn't really matter... Although maybe the fact that Gadgetbridge is pairing is the issue - maybe unpair and then repair with Android OS's menu and see if that helps?

    When you're outside of the camera app I think if you press the shutter button it should show the volume going down

  • Ok awesome, I was able to get it working. What I needed to do, was to disconnect the Gadgetbridge connection to the device.... and reconnect using only the devices Bluetooth pair to the Bangle.Js2. I then was able to take a picture. Then, I was able to reconnect to the Gadgetbridge pairing, and the camera shutter app still worked... so all great there!

    However, a new issue that I have noticed that has just been created...... Now, if my Bangle is connected to my phone using Bluetooth (even if it is disconnected from Gadgetbridge) my phone's keyboard does not work.

    So if I go to text someone, or open my browser to type in a search or whatever... the keyboard does not show.

    I have to disconnect the Bangle's bluetooth connection to my phone... and my keyboard will work again.

    I have tried turning off the HID on the Bangle. (and reboot the watch)... still, my phone keyboard does not work with the watch paired on Bluetooth. Any suggestions? Thank you, really appreciate your help

  • Actually it looks I solved this problem... in my phone's bluetooth settings page where it shows the connected devices... I clicked on the settings icon for the Bangle's connection... I clicked on Keyboard settings.. and made sure that the option for "use on-screen keyboard" was checked on... meaning that even while the watch is paired, to continue using the on-screen keyboard instead of the Bangle's "Keyboard"

  • Great! Glad you got it sorted!

    I clicked on Keyboard settings.. and made sure that the option for "use on-screen keyboard" was checked on...

    I was going to suggest this - but I'll make sure I add it to the FAQ on the Wiki page

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Troubleshooting to get the Camera Shutter App to work?

Posted by Avatar for user158136 @user158136

Actions