Pebble Clock With Distance App

Posted on
  • Had this watch a few days now from new, and can't change the Default Settings on the Pebble Clock With Distance. It is currently set to 0.75m and says it can be changed in settings. Everytime I change by scrolling up or down then tap to set it shows and sets the new step length number, before moving out of the settings and back to the watch clockface.
    When I return to the settings later, the watch has returned the setting to the to the original defult of 0.75. Is this correct?
    I don't have any more apps loaded, except for an alarm. Firmware is up to date. My Gadgetbridge allows change from default and remains at the new distance. I tried making Gadgetbrige and the Bangle 2 the same set length, but this has not helped. I watched Gordon's video how to set these variables, and have set the watch as shown. I do not code and have no knowledge of programming, Thanks for any help in advance.

  • I've just looked into this, and it seems the settings app was a bit broken. The settings change you made did actually take effect and was saved, but when you reloaded settings it always showed 0.75.

    I've just fixed this and the change will now be in the development app loader (pebbled 0.06)

  • Thanks for your speedy reply and fix. I am struggling to pair and connect at the moment with the App Loader. Tried W10 Edge and Chrome on my phone and laptop. Must be settings somewhere. Bangle shows able to connect, Gadgetbridge connected, but nothing pairing.................

  • Can you give a rough estimate when Pebble Clock With Distance v0.06 will be available for download?

  • It's already on the development app loader, which you can access via the 'More...' tab of the official app loader.

  • Thanks for pointing me to the right direction. I have made the upload and will check it out tomorrow, thanks again.

  • Step count today is currently 7146 (and rising). At least 7000 steps were recorded two/three hours ago. Gadgetbridge is slowly recording the additional steps with each *Full Synch on the phone, but NOT from the earlier walk. Bangle still showing the earlier 7000+ steps on display of Pebble Clock WD (and more recent additional steps),**but they are not being transferred? I checked activity today on the phone and its showing only steps from a couple of hours ago. The earlier walk is not currently shown anywhere on the phone.
    I'm guessing a Bluetooth disconnection. Does Bangle 2 transfer these steps on reconnection to the phone if there's been a break in Bluetooth earlier today? Or maybe if Gadgetbridge had the break? I checked yesterday's step count and it shows the total, as far as I recall. I'm on V20 version.

    *Is this the best way to update?
    **should have said that only the newer steps are being transferred over.

  • I'm guessing a Bluetooth disconnection. Does Bangle 2 transfer these steps on reconnection to the phone if there's been a break in Bluetooth earlier today?

    Do you have the Health app installed or did you uninstall it?

    Someone posted up with an almost identical problem a week ago and it was because they had uninstalled Health.

    What happens is every 10 minutes data is sent to Gadgetbridge when connected. But if you're disconnected then when it connects it tries to sync the data with what the Health app has saved - but if you remove the Health app it doesn't save any health data so it can't sync

  • Yes, Health Tracker is on. I can see graphs of steps etc on the Bangle, and timer is set to 10 minutes. Bluetooth is at Connectable and I have tapped Make Connection Stay On, to Yes. I have swapped Bluetooth on my phone to show Visible to all devices, then back to Only visible to paired devices. Back to Gadgetbridge again and still waiting to reconnect, hanging for a very long time. Then press three dropdown buttons to disconnect or reconnect whatever. Back to Waiting to Reconnect. This morning I tried away from the house and interference,but got the same result, phone was close and fully charged. Today there are steps showing on both the Bangle and Gadgetbridge, but the connection is predominantly unconnected or waiting to reconnect. We had an ancient Mi Band working on my phone which worked ok, now back on another phone and working within the same conditions. No other devices connected. Incidentally earphones pair and work straightaway on my phone (not sure if thats relevant). Sometimes I have forced a connect using 'Full Sync' in activity section, on Gadgetbrige but usually it disconnects. Running out of ideas.....

  • Stuck on 'Waiting to Reconnect' doesn't sound normal...

    By default many Android devices do some very aggressive battery management which can shut Gadgetbridge down any time it's in the background (which is when you want it!).

    Maybe you could check and see if you can do anything to stop Gadgetbridge getting shut down in the background - that could really help you.

    now back on another phone and working within the same conditions

    Not sure I understand - you're saying the connection is more reliable on a different type of phone, or the same?

  • Thanks for the Don't Kill My App tip. My dreaded Huawei is top of their list! You must be psychic. I followed through changing as many settings available to me on the EMUI version, and all is connected. For the moment, I am keeping the phone and Bangle close to ensure short range bluetooth distance.
    Pity I didn't wait for your reply. In my frustration I wiped the custom rom which was installed initially, to stop Huawei constant reporting and intrusions, reluctantly reverting back to stock Huawei Emui. All is not lost though, with the DKMApp checklist, comms between watch to phone working again. Will revert to a custom rom again asap.

    PS: Yes a tips type section on here would be useful to me (cant find the original post).

  • Yes a tips type section on here would be useful to me (cant find the original post).

    There is and maybe more importantly a Wiki with common questions in:­iki is in there - it's just hard to know where to link it from to make it more obvious to folks (we link from the Quick Start and but there's so much info it's easy for things to get hidden)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Pebble Clock With Distance App

Posted by Avatar for user157383 @user157383