[SOLVED] Cannot pair Bangle.js 2 with Gadgetbridge

Posted on
  • I recently started playing with my new Bangle.js 2. When attempting to pair the watch in the Gadgetbridge app, I get this toast: Bonding with %1$s failed immediately after the phone attempts to pair for 10 seconds or so.

    I made sure that all the permissions are granted to Gadgetbridge.

    I tested with these versions of the Gadgetbridge app:

    1. Bangle.js Gadgetbridge on F-Droid
    2. Gadgetbridge on F-Driod
    3. Bangle.js Gadgetbridge on Aurora Store
    4. Bangle.js Gadgetbridge on Google Play Store

    I made sure to update all apps on the Bangle.js 2 and used the "Install Default Apps" option on the App Loader multiple times (followed by installing the Android integration).

    I restarted my phone between tests.

    I made sure I was far away from other Bluetooth devices when trying to connect.

    I run GrapheneOS, so I also tested with the "Exploit protection compatibility mode" setting enabled.

    Google Pixel 7
    Android 14 (GrapheneOS 21)

    I might be able to test with a stock Pixel 6a in a few days as well.

    Gadgetbridge debug log attached.

    1 Attachment

  • Hi - this could well be a GrapheneOS thing as Bangle.js should 'just work'.

    One thing you could try is on the Bangle, enable Passkey in Settings -> Bluetooth.

    It might be GrapheneOS adds a restriction that it won't bond to a device unless that device has a passkey, as maybe it thinks it can't be trusted if it doesn't.

  • I should add though that you don't have to bond - so when Gadgetbridge asks you if you want to you can always answer No.

    In that case the connection to the Bangle won't be encrypted, but honestly the chance of someone deciding to sniff Bluetooth traffic to get the contents of your notifications for most people is pretty slim.

  • No dice, unfortunately.

    I figured it could be an issue that was specific to GrapheneOS, but I had seen at least one post from someone saying they had theirs working on GrapheneOS without issues, and I've seen tons of others using Gadgetbridge with other watches with no problems.

    As an extra data point, I can pair the watch using the system bluetooth settings, just not in Gadgetbridge.

  • Interesting. Thanks!

    I'll still test this with my partner's Pixel 6a this week, but this works great as a workaround.

  • but this works great as a workaround.

    You mean choosing not to pair?

    Actually I believe if you choose not to pair, but still have a passkey, the pairing will still happen (just in the OS, unknown to Gadgetbridge) and the communications will be encrypted - so in that case it'd be pretty much perfect.

  • Good to know. Then it's solved. Thanks!

  • Just got my Bangle.JS 2 yesterday. I'm having a similar issue, but I cannot even get my bangle to pair to my Pixel 7 with GrapheneOS. Reading this "solved" thread I'm not understanding what the resolution was.

    OS and hardware:

    • GrapheneOS on Pixel 7
    • Ubuntu 23 on dell laptop
      • Asus USB-BT500 usb bluetooth adapter

    Behavior and troubleshooting:

    • Originally showed up as a device in GrapheneOS, and in Ubuntu on my laptop.
    • It would not allow me to pair and load apps in brave(as said in the docs), but it does allow me to pair and load apps in ungoogled-chromium without any issues as long as the proper chrome flags are enabled
    • After disconnecting from ubuntu I tried to pair with my pixel, originally it would show up and allow a pair, but not let me do anything with it, then it would show up as a pairable device, but not let me pair just does nothing when I tap on it. Now, sometimes it'll show up and sometimes it won't.
    • Gadgetbridge does not see it even when my bluetooth does
    • My work device, a macbook pro would not even see the device in bluetooth.
    • It pairs without issue on my old Galaxy S10e, but says it needs an app for the device
    • A lot of the time I have to quit settings, turn off bluetooth, open settings back up and turn it back on to see the device again in both Ubuntu and GrapheneOS
    • I have never had any issues with any bluetooth devices on Graphene, or Ubuntu with my usb bluetooth adapter.
    • I noticed at one point either on ubuntu or graphene when I selected my bangle the bluetooth symbol on the bangle would flash blue for a sec every time I selected the device to connect. I do not remember which device this was on and can't seem to reproduce it.
    • I've factory reset my bangle once.
    • I've tried using the gadgetbridge app from the playstore, aurora store, and F-droid
    • I've tried connecting on my profile with google play services enabled and my profile that has google play services not installed

    Any help would be appreciated

  • Lets discuss this in the new thread you created on https://forum.espruino.com/conversationsĀ­/393304/#comment17259552

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[SOLVED] Cannot pair Bangle.js 2 with Gadgetbridge

Posted by Avatar for thejevans @thejevans