Left handed rotation issue in settings app

Posted on
  • Hello,

    Is anyone else having Settings App display issues when they rotate their Bangle.js 2 to "Left Handed"? For me, the chevrons and check boxes don't show up correctly. Sometimes clicking where the checkbox should be will make parts of it appear, but not always (it does toggle it every time though). Attached is an example screenshot where you can see the "Wake on Button" checkbox half drawn, and the "Wake on Tap" not appearing. It seems that generally the initial chevrons and boxes show up and it's issues with scrolling. Number and text values on the right work properly.

    Firmware 2v19
    Apps up to date (Settings v0.68)

    Thanks in advance for your time.


    1 Attachment

    • rotateissue.png
  • Hi - thanks for the screenshot! I can just tested and I can reproduce here.

    So it's just icons in the scroller that are having issues?

    I've just filed a bug for this at https://github.com/espruino/Espruino/iss­ues/2435 - I found a quick bit of code to reproduce, and hopefully I'll be able to get a fix in in the next week or so.

  • I just installed the standard Launcher (I normally use Desktop Launcher) to test that on a hunch and it looks like the app icons suffer the same issue when scrolling there as well. I'm not sure what else might be affected but it does seem to be just icons while scrolling.


    1 Attachment

    • icons.png
  • Just fixed! If you try a cutting edge build in a few minutes when they've had a chance to update I think it'll be fine now

  • Amazing! So fast! That seems to have taken care of it. Thank you!

  • I updated to 2v19.75 after seeing this thread since I'd like to wear my watch on my right hand and then noticed that my messages are no longer being retained on the watch. The notification that I got a message will appear, and then the message will disappear as if I had dismissed it. This happens with all messages, and they don't show up in the messaging app either. I updated to .79 today, but the issue persists. Is this problem unique to me?

  • Actually, now that you mention it, that seems to be happening to me right now as well. I'm probably misremembering but I could have sworn it was working correctly earlier... Attached is the debug log from receiving an email and another from a chat message.

    2v19.79
    GB nightly 0.76.1-banglejs-66b36564a

    edit: updated to GB Nightly ae75f82a6 and replaced attachments with bangle debug and matching gadgetbridge log of same issue on latest versions


    2 Attachments

  • Maybe you could try the latest firmware build? I think 2v19.75 may have introduced some issues with JSON parsing that could have messed this up

  • It looks like an issue on 2v19.79 (latest cutting edge) as well. It wakes up the watch and opens Messages but doesn't vibrate and says "No Messages"

  • That's odd - I just opened the IDE and pasted in GB({"t":"notify","id":1701146769,"src":"­Proton Mail","title":"root","subject":"","body"­:"bangletest","sender":""}) from your log file, on a latest version of the firmware while on the clock (and left handed mode) - and it displays the message just fine.

    Or are you referring to what happens if you manually start the messages app?

    If so I think I just spotted an issue, so the new cutting edge build should have that fixed - sorry about that!

  • Weird, for me it was just when messages came in normally, maybe because of the messages widget or fullscreen notifier? Either way, it seems to be working properly for me now in 2v19.84. Thanks again! You're the best!

  • Updated to .84 and the problem is only partially solved for me. The message dismisses itself still so that the widget doesn't display, but I can see the message in the messaging app now. I'll have to provide a log later.

    EDIT: Log sent via DM. I got the pop up notification, but no widget appeared after I ignored it to show that there was an unread message on my phone. The messages were accessible from the messaging app like normal, however.

  • @user156982 interesting - I think it probably depends on the clock you're using. If the clock supports 'fast load' then it can unload itself and can go straight to the messages app without having to save (which I guess is what happened for me).

    @houshou_m strange - so your issue is really that the message widget doesn't appear? Looking at the data you sent. It looks like specifically for SMS, no src is sent from Gadgetbridge so the message doesn't have an icon and never appears in the widget bar. Other apps should work though - I'll look into fixing SMS on Gadgetbridge

  • I'm happy to report that everything is fixed for me as well. Thank you!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Left handed rotation issue in settings app

Posted by Avatar for user156982 @user156982

Actions