Bangle.js 2 not getting a GPS fix

Posted on
  • Since some weeks I am not able to get a GPS fix anymore (from the run app, or from the bike speedometer).

    I've uploaded the AGPS data through the Assisted GPS Updater or A-GPS Data Downloader App, and waited for more than 3o minutes, but got no fix.

    I've tried to reboot, factory reset, flash other firmwares (I've tried the last 3), play with the "override GPS from Gadgetbrige" option , but never got a GPS fix.

    The GPS through Gadgetbridge works though.

    Can it be that the GPS chip is broken?

    Is there something I can try before I order a new device?

  • Hi,

    Did the Bangle work fine before? And is all the firmware and software up to date?

    And when you're waiting for a fix, did you wait with the Bangle not moving, somewhere where it could 'see' a decent amount of sky without buildings in the air? I've always found is surprising but the Bangle really hates trying to get a fix when it's moving about.

    If you connect with espruino.com/ide and type Bangle.on('GPS',print);Bangle.setGPSPowe­r(1) on the left do you see anything on the console?

    In the past I have found that with the 'GPS from Gadgetbridge' changes I did get to a point where the Bangle never appeared to get a fix (but never actually turned GPS on), but after turning that off (I think it's just Overwrite GPS in the Android app on the Bangle) it worked. I've never had it recently though.

  • Hi Gordon, thanks for your answer.

    It used to work until some weeks ago.

    I've tried everything you suggested, with no luck.
    I'm using the latest stable firmware version (but I tried 2v16 as well).
    The Overwrite GPS option did not help.

    I downloaded the latest AGPS data, then ran your code for ~20 minutes with the BangleJS sitting still outside, on a spot where it used to get a fix very quickly and got a series of messages like

    { "lat": NaN, "lon": NaN, "alt": NaN, "speed": NaN,
      "course": NaN,
      "time": Date: Tue Aug 8 2023 00:24:34 GMT+0200,
      "satellites": 0, "fix": 0, "hdop": 25.5 }
    
  • Sorry to hear that - it definitely sounds like a GPS issue then. I'm running out of things to suggest. Perhaps try running it down completely flat (there's a utility in Settings), leave it for a few hours and then charge it again, just in case GPS chip has got into a weird state and needs a restart.

    The GPS chip itself appears to be working (as it's showing you a time in the GPS report there) but I guess it's possible the aerial has got broken somehow, in which case I don't think there's much we can do.

  • I thought that, thanks anyway

  • I had similar problems with the GPS fix. Your answer helped me a lot. I know now, that my Bangle.js 2 is not broken. Thanks a lot! Keep goin!

  • Hi all, I'm also struggling using the GPS. Last week I was able to get a GPS Fix (don't know the correct terminology) after 40 minutes of waiting. Then I had to restart the watch and, trying again, GPS Fix didn't work. I tried again yesterday. Another ~40 minutes and got it working. Stopped the GPS Info app, started it again, and after a few seconds GPS Fix was working again.

    Yesterday night I tried again, no luck. Waited more that 20 min, than had to go back inside.

    Evey time I try I update fresh AGPS data.

    This morning I got the watch outside, after 20 minutes I connected the IDE and Bangle.on('GPS',print);Bangle.setGPSPowe­r(1) continues to give me a series of

    { "lat": NaN, "lon": NaN, "alt": NaN, "speed": NaN,
      "course": NaN,
      "time": Date: Tue Sep 5 2023 11:05:14 GMT+0200,
      "satellites": 0, "fix": 0, "hdop": 25.5 }
    

    The GPS Info app reports:

    in view GP/BD/GL: 0 4 4
    

    But still zero satellites used.

    The watch is still outside, I'm going to let it drain with GPS Info app opened. I hope this fixes it.

  • Checked again now (another 50 minutes passed). GPS Info says:

        in view GP/BD/GL: 0 4 7
    

    But still zero satellites used.

  • Stopped GPS Info. Now using "Flatten battery" from the Utility menu. :fingerscrossed:

  • Battery drained. Left charging for 3h. Took the watch outside. Started GPS Info and after 30 min the app is showing me the data. All good.

    Then I exited the app. Waited 30 seconds. Started again the app. After 5 min GPS Info started to show the date again.

    • I noticed that the watch never gets to “view” GPS satellites. Only BD and GL. Is that normal?
    • Is it normal that I have to wait 5 min to start receiving data from the satellites?

    Thank you!

  • I noticed that the watch never gets to “view” GPS satellites. Only BD and GL. Is that normal?

    In A-GPS Data settings I have "GPS" selected, so I don't think I have BD or GL working.

    Is it normal that I have to wait 5 min to start receiving data from the satellites?

    I don't think so. With AGPS data updated I get a fix after 5 to 10 seconds. If APGS is not up to date it takes minutes to get a fix, sometimes it doesn't get a fix at all. This is all outside. Are you sure you have AGPS data updated.

  • I update AGPS data always before launching the GPS Info app. I always upload all 3 datasets: GPS+BDS+GLONASS.

  • I update AGPS data always before launching the GPS Info app. I always upload all 3 datasets: GPS+BDS+GLONASS.

    Have you tried with GPS only? I get a very good precision with just it enabled.

  • You are right: Using fewer GNSS systems may decrease the time to fix. (If unsure, select only GPS)

    I’ll try again tomorrow only with GPS. Thank you!

  • Getting the GPS signal is a lot faster now, but the precision is far from usable in the city. I have to test it somewhere without high buildings. Anyways, that's another problem.

    Thank you for helping me out!

  • I recently had problems getting a fix. Normally I only upload GPS data, but this time I uploaded all available data (GPS / BD / GL). Apparently that made no difference, but when I uploaded only GPS, I had no more problems getting a fix. Maybe it was a coincidence, but since it only takes a short time, it might be worth a try.

  • Glad that sorted it! Yes uploading AGPS just for GPS is what I tend to do and it does seem to improve time to fix (I've just changed the updater app to make it clearer that's a good idea)

    But yes, with high buildings all around the Bangle will struggle a bit more to get a GPS fix. I think phone GPS is so good now it's easy to forget what 'plain' GPS used to be like - I remember driving through London with a windscreen-mounted GPS and having it lose GPS signal multiple times.

  • @Gordon would it be possible to have an option to automatically upload fresh AGPS data when connecting to the watch via https://banglejs.com/apps/?

  • Potentially it would, yes... It'd require a little messing around to pull the code out of the assisted GPS app but it's definitely possible.

    If you just want to get to the AGPS app quick you can always use the link https://banglejs.com/apps/?id=assistedgp­s to go to the app loader though - so it's a few less clicks to get to upload AGPS that way

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Bangle.js 2 not getting a GPS fix

Posted by Avatar for Michele @Michele

Actions