Gadgetbridge is not connecting

Posted on
  • Hello,

    I put my smartphone to flight mode every evening. However, Gadgetbridge does not reconnect to bangle.js after turning flight mode off.
    Also manually clicking on connect does not help. The only solution I found so far is, to open, connect to my device and than Gadgetbridge gets the connection. I attached a short video.
    If I don't do the Chrome connection, Gadgetbridge is not going to connect to the watch.
    If have the same problem with my other watch.

    I'm using Bangle.js Gadgetbridge 0.73.0-banglejs on an Pixel 6 running CalyxOS 4.8.0. But I had the same behaviour also on my previous Android Stock phone.

    Does anybody has similar problems with re-connection after flight mode?

    1 Attachment

  • Same here, I quit and then start the Gadgetbridge app to get it working again. Sometimes a restart of the watch is also needed.

  • And you definitely have the 'auto-reconnect' option set in Gadgetbridge?­ra-setup

  • @Ocim Can you check if my workaround (connect to App Store, disconnect App Store, Connect Gadgetbridge) does also wokr on your side without restart Gadgetbridge?

  • @Gordon In fact, it was deactivated in the GadtgetBridge global settings, but activated in the Device-specific configuration. However, activating it in both places does not solve my problem.

    I think the problem is not that GadgetBridge it does not initiating a reconnect, but that the reconnect fails.
    As you can see in my video, also manual reconnect does not work until I head over to the App Store.

  • @avanc, yes that works too. I think somehow the connection is not removed on the watch when the phone switches off Bluetooth. If I walk too far from the phone the watch will reconnect to it when I return in range. But if I turn off Bluetooth it does not reconnect after turning Bluetooth back on.
    Can you try if the watch reconnects when you walk out of range and then return in range?

  • (updated)

    My below issue was caused by a missing preference inside GB, and specifically a checkbox in the bangle.js connection (Auto reconnect to device)

    Time ago my bangle.js1+GB connection were very stable and lasted for many hours.
    However at certain moment, GB connection began too fail after short periods, I didn't say anything as i though that a newer version will correct.

    After a while i decided to check the phone configuration, and then I granted permissions and i added GB to the exclusion list on saving battery. But it is still getting disconnected after after short periods.

  • @Ocim Reconnection after out of range works without a problem.

    @dapgo I also removed GB from battery saving.

  • Hi there, been a while since I've been on here but I ran into the same issue and checked here to see if anyone else had too. Good to see I'm not the only one.

    I tried your workaround and it works for me too but I think I've found a more permanent fix.

    The Gadgetbridge guide on Espruino says to select 'don't pair' when setting up Gadgetbridge with the Bangle.js as it gives the most reliable connection . However, in my experience this results in the connection issues.

    When I select 'pair' instead, the bangle auto connects like it's supposed to. I've tested this and it works even after flight mode is turned on and off or if Bluetooth is turned on and off.

    Hopefully it works for you too :)

  • @sconniebotland Thanks for the suggestion. I can confirm that it works with 'pair' as expected!
    The watch is connected immediately after switching flight mode off!

    Thats great :-)

  • Great news - thanks! Please can you update in a few days and see if it keeps working reliably, and if so I'll update the docs

  • Yeah of course. So far so good but I'll keep an eye on it over the weekend and update next week :)

  • I can confirm the same. Thanks!

  • @Gordon It works since 10 days like a charm. Bangle.JS reconnects is all cases within seconds. Today, I updated to Firmware 2v17 without regression.
    It's now definitely in a state where I can recommend the Bangle2 without concerns to my non-techy friends.

  • I agree and for me the battery also lasts longer now

  • Ok, great! I'll update the docs then - I'm surprised about the battery though (I wonder if that's not related to Pairing)

    And thanks @avanc - I'm glad you're enjoying it!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Gadgetbridge is not connecting

Posted by Avatar for avanc @avanc