• Well I'm off to a great start! I installed the battery connected to the device then used the IDE to turn the lights on and off. The IDE said there was a new firmware for my Puck 2.1a so I followed the instructions. Downloaded the zip for the Puck then used the IDE to install the firmware that was downloaded, I put the device in the bootloader mode (green light on, pushing the button when putting the battery in). The I paired with the device "Dfu...." (something like this). that's when I got an error saying the device was not in a valid state AND now the Puck is dead... If I just put the battery in nothing happens. If I put the batter in and hold the button for any amount of time (I've tried a couple dozen times at this point) all I get is a Green LED and I can't connect.

    Any help? I had a super simple project I wanted simply turning a LED on when motion was detected and now I'm dead in the water. Haven't even had a chance to play with it for more than an hour :(

  • So if I put the battery in no red light and if I push the button after a period of time the green led comes on and stays on.

  • Ok, I think the firmware update has failed. What device did you do the firmware update from? The IDE?

    The bootloader will still work fine though (hold the button down while putting the button in) and the green LED will light (in fact you just holding the button down may have done it too)

    Please could you try following the steps on https://www.espruino.com/Firmware+Update­#nrf52 ?

    If the Web IDE update failed, using a phone app would likely work just fine

  • I got it sorted out! I had to use the mobile DFU app but then I was able to put the firmware on my puck and I got it sorted out. Thanks for the response back to coding :D

  • Great - glad you got it sorted in the end!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Just got my Puck today, tried to upgrade firmware and it's not working

Posted by Avatar for user153098 @user153098