• After having uploaded a big splash image with require("Storage").write(".splash",E.toA­rrayBuffer(atob("
    my Pixl is frozen.

    So I do a hard-reset, power off/on with BTN1 pressed. It starts, then displays:

    DFV 2V16

    Then the led flashes once, and the screen is frozen with the same message.

    Possible reason: a JSA connector I soldered two weeks ago, but it was working OK after that.

    I am happy to try to flash the memory myself.

  • Argh, that's a pain. Do you know exactly what the file you uploaded was? It'd be handy if I can see exactly why it broke things.

    ... But I just made a change to the firmware - if you flash the latest cutting edge Pixl.js firmware via DFU then reboot and hold BTN1 and BTN4 while loading, the splash screen won't be loaded. So then you can delete it from storage and next time the Pixl will boot fine

  • Please find attached the whole script and the image.

    Also: I did not save this program to flash memory, so maybe the hardware is broken ?

    I will flash the latest firmware and will tell the result.



    2 Attachments

  • As kindly suggested, I tried a DFU reset with "Cutting Edge build: espruino_2v16.93_pixljs.zip"
    I attached the Android displays, after the sequence:

    DFU 2V16
    <=============      >

    ... then pressing BTN1 gives:


    Please that it does NOT display this, the end after "START" is missing:

    1 Attachment

    • Screenshot_20230202-200316_DFU.jpg
  • Hi - you'll need to connect to the device called 'DfuTarg' that appears. If it's connecting to Pixl.js ... as it seems to be in the screenshot, that's the device's name when it's not in DFU mode.

    There's a bit more info about exactly what steps you need to follow here: http://www.espruino.com/Firmware+Update#­nrf52

  • Ah OK, my mistake.

    Unfortunately, it blocks (BTN1 only, or BTN1+BTN4) with the message:

    DFV 2V16

    If it is a hardware problem (shock or any other reason), it might be simpler to order another one. I can send you mine for further investigation.

    1 Attachment

    • Screenshot_20230203-230855_DFU.jpg
  • Wow, that is extremely strange. At this point it really shouldn't be a hardware problem - it obviously works well enough to use Bluetooth, look at the buttons and control the LCD, so from there on it should be able to boot to Espruino just fine.

    I just tried uploading exactly that firmware and it worked fine for me here...

    Please could you try the upload again (and re-download the zip) just in case? And is it possible to send me a video of exactly what happens when you hold down the BTN1+BTN4 while applying power to the board?

    On mine it looks like this if I boot it while holding the buttons:

    DFU 2V16
  • Same message.

    I sent a Wetransfer URL to the email address contact at espruino dot com .

    If this helps, I am absolutely happy to send it to you, and order another one.

  • Hi - sorry for the delay. Thanks for the video - it does seem strange - I'm not sure there's a great deal that can be done to fix it remotely (unless you have an SWD programmer!).

    I just checked and you're in the UK? If you can send it back then that'd be great I'll take a look at it, fix it and send it back - it'd be good to see what's gone wrong.

    If you actually wanted to order another one then let me know - we can just send you a replacement along with your order.

  • Hi Gordon,

    Just received my new Pixl and immediately I tried the same experiment with the attached Javascript file:
    (1) Upload the file without 'require("Storage").write(".splash"' => Works fine.
    (2) Upload the file WITH 'require("Storage")..."

    Same problem.

    It does not reboot, with the message:

    DFU 2v16
    BOOTING ...

    When trying to boot with BTN1 and BTN4 pressed, it displays:

    DFU 2V16

    What do you suggest, please ?

    1 Attachment

  • Hi! Sorry I missed your post and didn't sent out a replacement Pixl with your order.

    Gordon is on holiday next week, but I'll make sure he gets back to you when he is back.


  • Dear Christine
    Thanks for your answer.

    No worry, we will investigate the problem when is back.

    Kind Regards,

    Remi Chateauneu

  • Sorry for the delay - I'm back now and have your Pixl here, and I'll see if I can sort this out later tonight. It should just be a matter of a firmware update.

  • Ok, sorted! This is particularly annoying...

    Basically, I did manage to fix the issue originally, but the CI builds weren't updating - so the firmware you uploaded before ended up being an out of date one :(

    So if you update now, you should get firmware 2v16.162 and that should be a lot better.

    • BTN1+BTN4 will stop the splash screen being loaded and it'll boot (as before)
    • The image you uploaded won't crash it now (it gives a warning)

    The underlying issue was I think you must have copied the image from the 'image object' I think, rather than just using 'image string'. As a result you weren't actually getting a real image, but were just inputting the bitmap data in directly. In this case it just happened to be an almost (but not quite) valid image - it turns out a 32 bit palette isn't a good idea on a device with 64k of RAM :)

    I'll get your Pixl sent back to you as well

  • Thanks, it arrived yesterday and the second Pixl was reflashed as explained : Perfect.

    And indeed the warning is: "Uncaught Error: Can't have palette on >8 bit images"

    But I created it with "Output As: Image String" and "Coloours : 1 bit black/white" options. Not a problem.
    Many thanks again.

  • Great! That's very strange about the image though... I can't seem to get anything like that from the source image you provided above (although Espruino does only support up to 256 high/wide images as image strings and I wonder whether that could have been an issue)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Pixl frozen in hard reset, after message "BOOTING..."

Posted by Avatar for rchateauneu @rchateauneu