Bangle.js 2 won't boot after firmware update

Posted on
  • Hello,

    I just unpacked my Bangle.js 2 today and tried to update the firmware using the App Loader. Everything went as expected until in the middle of updating the firmware the bangle.js got stuck in some kind of loop. I made a video for reference:­eature=share
    First part of the video I am not pressing the button, in the end I am pressing it and try to boot.

    The problem is that I can't escape this loop, no matter how long I press the button (and believe me I tried really long). Furthermore, I can't connect to the App Loader or IDE anymore. So I don't know how to reach out to my bangle.js.
    If I release the buton while it stacks the ====== bar I can get onto one screen saying


    but don't know what to do with it.

    It would be totally fine if there would be a way to just reset everything. Scince it is new I didn't do any personalization except for setting it to the right time. :)

    I am also not really experienced in this kind of field. I want to use the bangle.js to try out some things myself and learn. So it would be really nice if your answers are kinda noob-friendly.

    I already read through this thread but it does not seem to be the exact same problem, or am I wrong?

  • The problem is that I can't escape this loop, no matter how long I press the button (and believe me I tried really long).

    you are causing this loop by holding the button. when you hold the button for longer time it triggers watchdog reboot (message WATCHDOG) so don't do it.

    if it is stuck after Storage OK with older firmware and then does watchdog reboot too without holding the button it is the bug discussed in few topics here, one is­/380541/

    when it stays in "DFU START" mode you can upload latest firmware zip from via Android nrfconnect or nrftoolbox mobile app. Then it should start working.

  • Hi - thanks for the video!

    I'm sorry you'e had troubles with this pretty much out of the box. It sounds like you hit the issue @fanoush mentioned.

    Basically if the storage had got corrupted somehow, the 2v15 firmware had some optimisations and those unfortunately didn't check for the corrupted data and caused it to hang when booting. I'll release a 2v16 firmware that has it fixed soon, but until then you can use a 'cutting edge' build that has the fix in (these have all the latest changes in).

    Unfortunately because the watch is not booting into the Bangle.js firmware you can't use the firmware updater app to re-upload a new firmware, so instead you'll have to use the fallback method using an Android/iOS app - there are some instructions here:­#android-ios-app

    Sorry again about this - and hope that helps!

  • Hi fanoush and Gordon,

    thank you both! I managed to install the new firmware using the android app. :)
    The step-by-step instructions you posted was what I somehow didn't find on my own. I just read about users installing a new firmware after experiencing the same issue multiple times here but they never explained how they did it in detail. Thanks again for the super quick replies!

  • This happened to mee too, and this guide helped me fix it! Thanks 😊

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle.js 2 won't boot after firmware update

Posted by Avatar for phunny @phunny