• I upgraded my Pixel 4a to Android 13 this morning, and now I can't get Gadgetbridge to connect to my Bangle 2. I've tried restarting the watch and the phone, plus pressing "disconnect" in Gadgetbridge and then trying to connect again, but nothing works. The app loader can connect to it fine, though.

    Is there any useful debugging I can do? Is anyone else having this problem?

  • Have you tried to "Forget" the Bangle in android bluetooth settings and pairing anew via Gadgetbridge? Or pair via android bluetooth settings instead? And also checked out "Discovery And Pairing Options" in Gadgetbridge?

    Have you tried clearing the cache or data in android app settings for Gadgetbridge? Or reinstalled the app?

    Maybe it should be added as an issue over at the Gadgetbridge repo on Codeberg?

  • ...huh, seems like it's connected now, weird, I don't think I changed anything.

  • Short notice: I updated my Pixel 5 to Android 13 yesterday and had no issues.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Gadgetbridge not connecting after upgrade to Android 13

Posted by Avatar for sorrel @sorrel