JS2 firmware won't upgrade

Posted on
  • Picking up the JS2 again after a couple busy months, I was immediately notified to upgrade my firmware via the Firmware Update app.
    It simply won't work. It just stops around 20%.
    I did a factory reset, and tried again, but that didn't help.
    I tried to use the old firmware update method via the DFU app, and tried again, but that didn't help.
    I set the screen timeout to zero, and used the coffee app to keep my phone screen from going to sleep, and tried again, but that didn't help.
    I'm out of ideas, anyone else overcome a similar issue?

  • So you used the Firmware Update app in the App Loader first? What kind of computer was that on?

    I've just tried again here and it works ok for me.

    I guess it might be related to one of the apps you had installed. Maybe when you get it working again you could to a backup from the app loader and send me the zip, so I can see if I can reproduce it.

    When you tried the DFU update, did you use Android or iOS? I know iOS has a weird issue where you just have to keep retrying and retrying and it does a little more each time, so if you can borrow an Android phone that might help - otherwise you can probably just keep trying on iOS and it'll get there eventually

  • This is all through Android, I've never actually figured out how to connect via a computer. Windows 7 and 10 I just can't get either jswatch to show up at all. In Linux I can get my computer's bluetooth to pair with the js2, but can't get the app loader or web ide to find the watch, paired or unpaired with the computer bluetooth.

    Actually, I've been hoping to get that figured out as well, to make it easier to type in notepad++ and not have to send a file to my phone to test through the ide there, but maybe that's another issue for another thread. I was working on trying to get the connection going through Linux a bit more today, but for now I'm gonna call it a night, and will try more things over the weekend.

  • Ok I got the DFU method to work, apparently I didn't have the watch in the right mode the first time.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

JS2 firmware won't upgrade

Posted by Avatar for NoMusicTuesdays @NoMusicTuesdays