V15 messed up my banglejs ?

Posted on
  • Whereas my banglejs worked pretty ok with latest V14, I decided to update it to V15.
    My time changed to 10 hours earlier (my locale is at UTC +10, and even though this setting didn't change, I mention in case it would be related).
    The screen displayed what's in the picture below. I got back to V14 and I'm having various issues I didn't have before. The BTHRM says that bthrm is disabled (it's on default mode). Also, this app quickly displays 4-5 lines of code when exited. Every action triggers a short apparition of the screen "updating boot 0...". The Pattern launcher doesn't work anymore.
    The screen often display this sign in the bottom >.
    I tried to restart the watch without code, but it didn't help. Any clu e?

    1 Attachment

    • issue v15.jpeg
  • Hello,
    I also updated to v15, this morning.
    The process completed successfully but then I was unable to launch any app (the screen displayed "loading" and then nothing else), the clock was set to GMT (I am in CEST), etc.
    I then deleted and reinstalled the settings app and, although all my previous settings were gone, I was able to restore them (including timezone).
    Now it seems ok .. (I hope).

  • Having the timezone change and debug messages on the screen is a sign that the '.boot0' file hasn't been updated correctly. I'm not quite sure why that'd be, but if you go to 'Settings -> Utils -> Rewrite Settings` then that might fix it.

    Also, can you check that all your apps are up to date? There were definitely some changes in 2v14 that caused some apps not to work (and they needed updates) but 2v15 itself didn't really change anything I'd have thought would be an issue.

    If you keep having issues, please could you choose 'backup' from the App Loader's More... tab and send me the zip that's created? Feel free to email if you want to keep it private - but that should hopefully allow me to reproduce the state of your watch and see what's going on.

  • Hi Gordon,
    indeed reinstalling the settings app solved the issue in my case.
    It was impossible to just rewrite the settings as the launcher did not worked.

  • On my Bangle the update generally worked. The only issue I have with v15 atm is that barometer does not seem to work. Barometer app displays 0 and

    : console.log(d);
    : // {temperature, pressure, altitude}
    =Promise: { }
    { "temperature": 0, "pressure": 0, "altitude": 0 }

    With firmware 14 the barometer worked a few hours earlier.

  • @user140377 does it work if you do a complete reboot (long press the button) of the Bangle? While the barometer code did change slightly, it was tested here and works fine (and again just now), and the change was only to make it more robust.

    However looking at the code there is a small chance that if the Bangle booted up and the barometer didn't respond the first time it was queried, the Bangle could get stuck in a state for that boot where it just reported 0 for pressure readings. That could be what happened here, but it's not something specific to 2v15 (and a restart should fix it)

  • I don't see a change after a restart. Still reads zero.

  • Hello,
    I also found a glitch with barometer readings in one of my apps.
    The first few values, after powering it up, were zeroes but then, after a while, it started reporting the altitude consistently.
    Wrt settings being corrupted, I found that all apps had them erased (as if the files were removed).

  • The 'Settings -> Utils -> Rewrite Settings` didn't work, so I solved this with a factory reset. Not elegant, but always very efficient. I updated to V15.1, no pb, everything work as expected.

  • @user140377 @GRikell please can you connect with the Web IDE and enter the following code?


    Please can you tell me what it reports? It should be either [ 88, 0 ] or [0, 16]

    And @user140377 does it still read 0 if you go back to version 2v14?

  • [Bangle.barometerRd(0xD0),Bangle.baromet­erRd(0x0D)]
    =[ 0, 16 ]

    After going back to 2v14 it still reads 0.

  • =[ 88, 0 ]

    But after that initial hiccup, after updating to V15, it is working fine now.


  • [0,16]

    Ok, that's good - it means you have the slightly newer variant with the SPL06 barometer in, and that the barometer is communicating fine with the watch.

    After going back to 2v14 it still reads 0.

    Ok, so I think that 2v15 was a bit of a red herring then. Please could you try:

    • Install 2v15 again
    • Ensure all the apps are up to date
    • Go to Settings -> Utils -> Flatten Battery and leave the Bangle off-charge for several hours to flatten itself.

    Put it back on a charger and long-press the button to restart it after an hour or so.

    Having a full power cycle done actually be enough to bring the Barometer back. It's possible that somehow during the flashing process it just got itself configured wrong and it'll need a power cycle to refresh itself.

  • ok, this is odd. I got back to 2v15 a few hours ago. I checked barometer about three times. Still zero.
    Just checked again for fun before trying above procedure, now:

    : console.log(d);
    : // {temperature, pressure, altitude}
    =Promise: { }
    { "temperature": 26.82648722330, "pressure": 1018.17897384550, "altitude": -40.95649506835 }

    I then did a long-button-press reboot, now reads zero again.

  • Did the flatten battery/Charge cycle. Barometer now always gives values, thx.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

V15 messed up my banglejs ?

Posted by Avatar for Fteacher @Fteacher