• Howdy,

    I built my own binary for the Micro:Bit v2, and downloaded the one from the repo, flashed both without error, but neither responds respond to console or BLE. I'm using the WEB IDE inside of Chrome latest.

    Also fail USB serial...

    Could their be an issue with the latest and greatest?


  • I've just flashed http://www.espruino.com/binaries/espruin­o_2v14_microbit2.hex as well as https://www.espruino.com/binaries/travis­/c660e28606aa5fd3f4cffa656df978e19e64fe3­9/espruino_2v14.150_microbit2.hex onto a micro:bit 2 here and both work great for me on serial and bluetooth.

    So I'm not quite sure what's going on for you. Is there a specific firmware build you tried from https://www.espruino.com/binaries/travis­ that didn't work?

  • Today both your binaries worked fine, my only issue is I may have fixed a configuration issue on the nRF device when I installed the correct version of Micropyhthon just to check the hardware was OK.

    Also I may have forgot to reboot my machine yesterday. Classic mistake.

    And I guess I copied over the wrong hex file from my build directory. I used "espruino_2v14.149_microbit2.app_hex" which probably short the softdevice.
    That was easy to do. My bad.

    I really appreciate you being so diligent and updating the Micro:bit v2, I really need the spearker for my project.

    Thanks for your help, Gordon.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Micro:Bit v2 latest build fail? ... espruino_2v14.149_microbit2 ... hex

Posted by Avatar for RandallSY @RandallSY