Unable to download Recorder-files in Gadgetbridge

Posted on
  • Hey everyone!

    I've been using my Bangle.js 2 for a while. I absolute love using it. I've ran into a new issue, however.

    Using Gadgetbridge I'm unable to download workouts through the Recorder applet. The apploader tries to fetch the data, but there's no browser popup for me to accept the download. This also means no file gets saved on my Android phone.

    Is this issue reproducible? Or could I help you out in any other way?

  • Hi,
    I noticed the same issue yesterday. Just switched to the Bangle.js version of Gadgetbridge about a week ago.
    I was able to download the recorder data by disconnecting from Gadgetbridge and connect via browser and web bluetooth.

  • Bingo, I use precisely the same workaround!

  • This exact thing got reported to the bug tracker just a week ago! https://github.com/espruino/BangleApps/i¬≠ssues/2073

    Basically it seems the app loader in Gadgetbridge can't pop up a 'save file' dialog, so it'll need a tweak inside Gadgetbridge to make it work properly

  • Allright, thanks. I'll use the GitHub Tracker in tje future!

  • I'll use the GitHub Tracker in tje future!

    This is fine - the forum is still the best place if you have problems as otherwise everyone ends up reporting issues on GitHub, when quite a high proportion turn out not to be software bugs.

    I was just surprised that this has been an issue with Gadgetbridge for quite some time and then it's come up twice in quick succession.

  • I have a similar issue since recently with my Bangle.js 2.

    I go on my Android phone to Bangle.js Gadgetbridge, the to the App Manager, Connect, Go to My Apps, (Then I have to refresh the app list because all apps are called unknown for reasons I don't know, maybe it's a related issue) , then I scroll to the Recorder App. Then I get the Recorder pop-up with in this pop-up a box with:
    Please wait

    Loading Track List...

    But the loading never happens. I know that it worked in the past.

  • Is this the case on:

    • the official App Loader?
    • the standard development App loader?
    • a custom app loader? (E.g. https://thyttan.github.io/BangleApps (Some apps have custom updates not merged to official repo))
  • The official App Loader (It is blank in Device specific settings)

  • Thats odd - you're sure it worked in the past for you with the App Loader in Gadgetbridge?

    If you disconnect Gadgetbridge, then go to https://banglejs.com/apps/ in Chrome and connect that way, does it all work ok?

  • I'm quite sure it worked in the past.
    I don't have Chrome installed on my Android. Only on my laptop. Connecting by USB my Android with laptop with Chrome is my current workaround...

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Unable to download Recorder-files in Gadgetbridge

Posted by Avatar for 7rozen_7ear_ @7rozen_7ear_