eof at line 37 of bootupdate

Posted on
  • hi,

    i've been developping my app for a few days and this morning i started seeing strange messages in the web ide. when running the code i got something like : uncaught syntax error got EOF in bootupdate.js

    i did not pay much intention since the app went to run anyway.

    however i now have the following problems :

    • no bluetooth (everything fails with some 'bluetooth' message on the watch face)
    • when i go to the menus i get an extra 'updating boot0' screen between each menus
    • the clock now does not use the timezones anymore

    i tried to reflash the firmware going into dfu mode with the android app
    and i think it went succesfully

    but still, the watch did not go back to life.

    this is a brand new watch i bought a few days ago.

    anyone met something like that ? any way to reset the watch ?

    help ?

  • to complement a bit, i tried Resetting without loading any code and i got to the logo.
    but then when trying to remove all apps the bluetooth fails again, displaying some

    -> bluetooth

    <- bluetooth

    on the watch

  • so, i found the factory reset in the menus. this did solve my problems.

  • Hi - sorry you've had issues with this. What is the firmware version on the watch right now?

    We did have some storage corruption issues with earlier firmwares, but with 2v14 especially, storage with problems do seem extremely rare.

  • hey no worry, it's back alive. a few fears along the road but the recoveries have been well thought.

    i had already updated to 2v14 before my problems.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

eof at line 37 of bootupdate

Posted by Avatar for wagnerf42 @wagnerf42