Bangle.js 2 button stuck

Posted on
of 3
/ 3
Last Next
  • My Bangle.js 2 keeps rebooting, it very much looks like the button is stuck.

    Monday morning everything was fine, but a few hours later I noticed it constantly rebooting, the <====> bar filling up, and the process repeating itself every 6 seconds or so. I tried draining the battery, but that didn't help.
    I even managed to briefly connect the IDE between reboots, which seems to confirm my suspicion:

    >(new Pin(BTN1)).read();

    Pressing the button feels fine, except that it doesn't have any effect.
    The last time it even came near water was when I wore it in the rain a few weeks back, so I'd be surprised if that caused it.

  • Ok, that's an odd one - do you still have the issue?

    You could try pushing the button down and wobbling it around in circles to see if that helps.

    Just in case you could try leaving it to completely flatted - which i guess won't take too long - and see if that helps - but it definitely sounds like a hardware problem.

  • Yups, it's still broken. I already flattened it a few times between retries and wobbling didn't help either :-(
    I don't suppose trying to force it out with some pliers has a great chance of leaving it salvageable...

  • Ok, that's a shame - I'll ask Christine to drop you an email about swapping yours

  • I'm having this same issue. The watch just keeps rebooting over and over again. Have you found any fix to this?

    1 Attachment

  • Sorry to hear that - please could you try just moving the button around side to side with your finger? It's possible that'll free it, but if not, I'll have to arrange a replacement

  • I've tried that with no success. The button presses and depresses just fine but it's as though it's shorted out. Not sure.

  • Ok, I'll ask Christine to get in touch about a replacement.

  • I'm also having this problem, since about a week ago, having used my Bangle2 since it arrived around Feb/March this year. I've tried wiggling the button around as suggested here, but that doesn't seem to make any difference.

  • Do you're saying it's totally stuck down rather than just unpressable? And there's still a 'click' when you press it?

    That does remind me though - has either you or @bendunc submerged your Bangle recently for more than a second or two? I did hear of some people having this when their Bangles got wet, and after drying out they started working fine again

  • Do you're saying it's totally stuck down rather than just unpressable? And there's still a 'click' when you press it?

    No, it's pressable and it clicks, but wiggling it around as suggested here does not make it become unstuck.

    That does remind me though - has either you or @bendunc submerged your Bangle recently for more than a second or two? I did hear of some people having this when their Bangles got wet, and after drying out they started working fine again

    Ever since I got mine I have worn it in the shower without any problem. I did fall (shallow) in a couple of lakes recently, but looking at my calendar and reflecting on when the watch stopped booting properly, I can't figure out if that happened before or after the watch got stuck in a boot loop. When I fell in I did get out immediately, so the watch should not have been below 1m and should not have been in the water for more than a minute or two.

  • @hedgeling well that would sound like a likely cause then - maybe there was a little bit of water got in - just enough to get into the button. Taking the Bangle in the shower definitely isn't something I'd recommend - you'd hope it would be ok, but at the same time that's on the limit of what it is designed to handle.

    Maybe could you leave the Bangle somewhere warm for a week or so (off charge) and see if after that time the button has dried out enough and has started working?

  • @Gordon I'll give it another week and then try again. I guess I was a naive buyer to think that IP67 would be adequate for these use cases. I hope the next iteration will be IP68 again.

  • @Gordon I haven't gone swimming or bathing with mine but I did quickly run it under the tap after working out several times. Honestly, I was under the impression that it was much more water proof than IP67. Maybe I was mistaken but I remember looking up the water proof rating that was on a card in the original package and being impressed that it could withstand pressure several meters into water, according to its rating.

    I've left the broken bangle out in my room (dry western US air) for several weeks and it still has this problem. Like hedgeling said, the button will press and depress and can wiggle it around but the board itself is registering the button as held.

  • @bendunc I looked back and I'm pretty sure the original cards (and in fact the current ones) say "IP67 waterproof" - while technically true (according to the manufacturer at least) I'll admit that saying "waterproof" is somewhat misleading and I've been trying to replace that with "water resistant" whenever I see it (I'll get the next batch of cards changed).

    IP67 spec does say "protected against short periods of immersion in water while under pressure between 15cm and 1m." but that's clean, cold water, and in reality when moving under water the pressure almost certainly exceeds 1m's worth. If you google 'can I bath/shower/swim with IP67' the advice is pretty clearly against it...

    I haven't gone swimming or bathing with mine but I did quickly run it under the tap after working out several times

    I honestly can't see a problem with doing that - and it could well be that the button issue in your case is unrelated...

  • I'm also having trouble with the button on my Bangle.js 2. It has been living on the charger on my desk for some time now and I thought I'd wear it out tonight so I connected it, updated to the latest firmware, even added a few apps but then suddenly the button doesn't have the tactile click to it and I can't get the screen to unlock. The button is springy, I've tried wobbling it around a bit to see if I can 'unstick' it but to no avail. There's no audible or tactile click and the device behaves as if it's not been pressed. No chance of water damage as it has been stored on the stand for the last few months. Fingers crossed it frees up but judging by this and other posts I've found it doesn't sound terribly likely.

  • nevermind

  • My watch no longer powers up, it doesn't appear to be charging any more and without a button to press I have no way to nudge it into doing anything. @fritzfritz did you manage to repair yours yourself? Curious if I can do the same.

  • I bought mine through Adafruit. They said they would replace it, and I filled out the RMA work(yesterday), but I haven't received the replacement yet(hopefully this week).

  • Ah fair enough, I backed the kickstarter so I doubt there's any warranty on my watch.

  • Sorry to hear this - there was a 1 year warranty on the KickStarter watches but I'm afraid we're way past that now.

    You my be able to fix it if you're up for a bit of a challenge - you need to warm up the front glass (but not past 100 degrees C or it'll kill the LCD) and then the glue loosens and you can pull it off with a suction cup. It's been suggested the easiest method is to use the heated bed of a 3D printer if you have one or have access to one.

    After that, it might just be that the button PCB has pushed up, and you can just push it back down - or I just received a few replacement button PCBs here that you might be able to use.

    Unfortunately doing that will almost certainly break the waterproofing on your Bangle...

    The other option is when folks have had problems with an out of warranty Bangle, I've been offering a brand new one at half price - so we could do that if you wanted.

    @fritzfritz sorry you had troubles - you removed your original post so I don't know what the issue was, but generally it's helpful if you can give us a chance to try and help fix your problems before contacting the distributor.

  • sorry for the added noise, I deleted the post to reduce the noise.... and well.

    My watch is only a few months old. Starting last week the button stopped registering. It feels soft, instead of clicky. I guess I responded to the wrong thread, there was one that discussed the button dislocating. These symptoms fit with what I encountered. The only options I saw were to repair it (risk overheating and losing waterproofing) or try and see if there was a warranty. That's why I contacted the distributor. I apologize for not following through here first. I was in a rush to try and get it working again.

  • No problem - thanks for explaining! Just for others - it's extremely rare that we'd repair a watch for you, we usually just send a new watch body if there's something wrong.

    Sorry you had issues with it so soon though - after the initial KickStarter batch of watches the buttons have tended to be pretty good. Hopefully Adafruit get it sorted for you quickly!

  • I'm definitely up for repairing it and will have a go at removing the front glass with my printer's heated bed. Thanks Gordon.

  • @markcra great! Just to say that if you do get it to bits and you find the button PCB is damaged (rather than just moved out of the way) then I have now managed to get hold of a handful of replacement button PCBs, so I can post one to you.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle.js 2 button stuck

Posted by Avatar for rigrig @rigrig