Firmware upgrade won't start

Posted on
  • I'm trying to upgrade from 2v12.111 to 2v13 using the Firmware Updater.

    I can pick the firmware file as usual and then click Upload, but while a progress bar appears on the watch (and does nothing), the progress bar appears on the web page only briefly before disappearing. Nothing further happens.

    I've tried on my Android phone and a PC.

    I've also tried the 2v12.126 and plain 2v12 with the same results. Same with the development app loader.

  • Seems to work for me. On your PC, do you see any warnings/errors in the chrome dev console?

    Have you tried more than once?

    Normally if there's an error it'd show a 'toast' popup at the bottom of the screen with the error

    I guess it's possible that you don't have enough free storage on your Bangle to upload the firmware? You need at least 500k I believe - but if there's not enough space it should really show an error.

  • Also... has it ever worked from the firmware updater? What does the firmware update say your bootloader version is?

  • Ok, I just made some changes that should make firmware updates more reliable, or will at the very least make sure they tell you what the error uploading was.

    I found it pretty hard to reproduce reliably but did get once or twice. I haven't yet managed anything with the updated code.

  • @Gordon - whatever you've done, it's worked! Thanks.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Firmware upgrade won't start

Posted by Avatar for andrewg_oz @andrewg_oz